2019-06-09 04:42:11

so it looks like there's a small problem. Settings aren't saved on the Mac

2019-06-09 04:49:44

Hopefully I can fix the problem tonight.

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-09 15:00:00

I quickly fixed the options not saving bug.

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-09 16:31:47

This is seen in the Windows version too.

I love audio gaming!

Thumbs up

2019-06-10 21:23:24

The game is now not working again. Was working fine yesterday, however.

regards,
assault_freak

Thumbs up

2019-06-11 01:39:43

That's making tracking things down very difficult. The compiler I am using is very good IMO, but that weird issue irritates me. It should yield an error, but it doesn't for some reason. Maybe it's time to switch compilers? Arg!

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-11 03:48:52

Strange, it is working fine over here again. Had to update my windows and for some reason, when it didn't work before, my visual C runtime, wasn't working for some unknown reason. so there you go. Python, guess you strange. Hehehehehehe.

Jonathan Candler, A.K.A, Jonnyboy

2019-06-11 04:22:52

The only run-time difference I can come up with is internet related, so I guess I have to disconnect my wireless connection and see what happens.

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-11 09:14:58

The update list for 2.01 looks awesome, great work!
Though sadly, after upgrading I now have the problem people are talking about where running play.exe doesn't work and gives no errors either.  I tried running multiple times, tried running from command line and as admin, tried reinstalling including with default path but nothing.
I wonder if it's some kind of locale problem or something?

Buy the worlds greatest machine gun. It's about 50 inches in length, It's huge! & it can shoot really far, &, it's cheap!
Lets demonstrate this: stand still Thom...
Okay ma.aaa!
Oh! crap!

Thumbs up

2019-06-11 11:53:08 (edited by nyanchan 2019-06-11 11:55:45)

No. I've experienced the issue, too. What makes it difficult to track down is that it sometimes happens and sometimes doesn't. I'm guessing that the simplest answer is "Nuitka is still buggy".
But I'm kinda confused, honestly. You know, what is making the difference? We're running it on our computer. Computer! Computerrrrrrrr! Not a whimsy human or cat or bird or blah blah blah! So there must be something, but...

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-11 12:05:13

So, is there a change log which tell us what's new in the latest version?

Thumbs up

2019-06-11 13:07:15

changelog_en.txt

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-11 16:40:44

The game doesn't run on my Windows 7 machine. Now I don't know if I want to update it on Windows 10 until this is fixed.

Grab my Adventure at C: stages Right here.
You may access my NVDA Remote, Three-D Velocity, Sound RTS, and Road to Rage servers by using the address christopherw.me. Road to Rage uses the default 6789 port.

Thumbs up

2019-06-12 00:05:17

I just downloaded the newest update, ran the installer and now the game does not run at all. Is this the same issue others are having?

Thumbs up

2019-06-12 02:10:29 (edited by nyanchan 2019-06-12 02:42:44)

Yes yes, everyone is experiencing the same issue. I hate this compiler (it'd be great if it weren't so buggy). I still can't update the installer, so use this anyway until I can do so:
https://www.dropbox.com/s/ydlwnmpxnh3t5 … x.zip?dl=1

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-12 12:17:31

Hello.
I have a question:
Is there a change log to view in the game?
And, can I download the latest version in the same game directory?

Thumbs up

2019-06-12 17:36:51

Hello,
At post 166, the short answer to both of your questions is yes.
But also, I am going to clarify the error, probably the same error that everyone else has been getting, I just wanted to post it here just in case it had anything different in it that would help fix it. I just now installed 2.02 and am still getting it. Keep reading til the end of the error for a bit more info.
here it is.
Traceback (most recent call last):
  File "C:\nyanchangame\Screaming Strike 2\ss.py", line 28, in <module>
  File "C:\nyanchangame\Screaming Strike 2\ss.py", line 16, in main
  File "C:\nyanchangame\Screaming Strike 2\ssAppMain.py", line 56, in initialize
  File "C:\nyanchangame\Screaming Strike 2\window.py", line 33, in initialize
  File "C:\nyanchangame\Screaming Strike 2\accessible_output2\outputs\auto.py", line 12, in __init__
  File "C:\nyanchangame\Screaming Strike 2\accessible_output2\outputs\jaws.py", line 16, in __init__
  File "C:\nyanchangame\Screaming Strike 2\libloader\com.py", line 15, in load_com
  File "C:\nyanchangame\Screaming Strike 2\win32com\client\gencache.py", line 534, in EnsureDispatch
  File "C:\nyanchangame\Screaming Strike 2\win32com\client\gencache.py", line 391, in EnsureModule
  File "C:\nyanchangame\Screaming Strike 2\win32com\client\gencache.py", line 266, in GetModuleForTypelib
  File "C:\nyanchangame\Screaming Strike 2\win32com\client\gencache.py", line 552, in AddModuleToCache
AttributeError: module 'win32com.gen_py.F152C4EF-B92F-4139-A901-E8F1E28CC8E0x0x1x0' has no attribute 'CLSIDToClassMap'

Also, one more thing that may help, not sure if it does though, my main midi deice is not the normal Gs wavetable, instead it's Coolsoft virtual midi synth. It started up while I ran the game and it gave me the update notification right before the error happened. I have no idea if this has anything to do with the error, but it's consistant. As long as coolsoft is not running, when I attempt to start the game up, it starts with it. . The fixed zip you gave doesn't work either, unfortunately, same thing happens.
I hope you can get this fixed soon.

Thumbs up

2019-06-12 20:37:05 (edited by keithwipf1 2019-06-12 20:37:32)

Most confusing error ever.
Maybe Google knows something about this.
The problem might go away if Tolk was used instead, as AO seems to be running code that causes the problem.

My tactical battle scripts: https://www.dropbox.com/s/dzsmqv2pgqvu1 … h.zip?dl=1
Currently, one of my favorite games is Trimps.
So I'm the Trimper Trooper!

Thumbs up

2019-06-13 03:18:52

Hello, I was wondering if anyone else has trouble running te game?  I have windows 10 64 bit, have downloaded the game twice and all of the times that I hit play.exe nothing happened.  No music, no sounds, nothing.  I have also try to run the game as an admin permitions.  Any help would be appreciated.

Their is no such thing as a master.  One is never done learning, and those who claim to be a master at something are far from becoming one!!

Thumbs up

2019-06-13 05:10:07

@168
Thank you for your hint. I'm pretty sure that it's driver or COM specific problem and I cannot debug such an issue physically. I'll try switching to another speech library if possible.
@169 Please use the temporary fix that I posted 5 or 10 posts above.

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-13 05:30:47 (edited by nyanchan 2019-06-13 05:31:22)

Oh, for those who has the weird 0XA1bbccddewir034u9r08u34908urgf ish error:
I want to know if you have never been able to run the game after its 2.00 release, or you previously were able to play it.

I don't speak as good as I write, and I don't listen as good as I speak.

2019-06-13 11:34:22

I think this problem has accured here.
When I installed the latest version, then hit play.exe, Nothing happens, I try to run it as an administrator, but still

Thumbs up

2019-06-13 13:15:42

i have the same issue.

Thumbs up

2019-06-13 19:27:53

Use the rix that has been provided already. People should read messages further back than the last few... Yukio put up a temporary solution. smile
@171, I was able to play all the way until 2.01 when it suddenly started happening.

regards,
assault_freak

Thumbs up

2019-06-14 13:48:40

Yeah, same thing as 174, I played until 2.01 was released then I started getting this error.

Thumbs up