2021-04-08 10:05:59 (edited by afrim 2021-04-08 11:25:25)

Hey everyone,
It's been a long time since I've posted here.
As written briefly in the title, I have bought an Android TV. It is a Toshiba 43 inch device running Android TV 9. The problem I have with it is that I cannot turn on Talkback, despite the app being installed and updated to the latest version. The tv has also got the latest updates. What is really interesting, Talkback is installed on the device, but it doesn't show up on the accessibility menu, and the services heading is missing there. On the accessibility menu, I can find only audio descriptions, subtitles reader or so, hearing impaired, and AC4 Enhancement or something along those lines.
I've searched on google about this issue and it appears that many tv brands have this problem. I don't want to return the tv as it is a premium device that has every option one could want in a modern tv and I got it at a good price.
I tried contacting the google disability support via the Be my Eyes App, and although they were helpful and friendly, they couldn't offer any solution. I also contacted Toshiba regarding this issue and they stated that they don't make any adjustments to the system that would modify Android in any way. They were also unaware of any assigned shortcuts to accessibility services. I've also done a lot of research on the internet and it turns out that the best option is to enable the app manually through commands having android developer options turned on and using a PC connected to my TV in USB debugging mode. Of course, this is the last option I could resort to, but can you think of any other steps I could take in turning on Talkback?
I would sincerely appreciate any feedback from you.

Thumbs up

2021-04-08 12:36:03

maby try using google asistant?

best regards
never give up on what ever you are doing.

2021-04-08 12:47:47

Hi, it just says cannot change Talkback on Toshiba Cosmos. I've tried it both from my TV and phone.

Thumbs up

2021-04-08 14:20:59

ah... that's a shitty one... Maby try connecting it to the computer and enable talkback like that.

best regards
never give up on what ever you are doing.

2021-04-09 08:10:30

Hi.
Have you set the language to US English?
Toshiba have indeed messed up the accessibility in the tv. Otherwise it would have worked.
Some android tv's are only able to start Talkback when the OS is set to US English. I owned an Android tv long time ago. I'll never choose that again.
It's a shame to read that people are still having those issues, because Google allows companies mess with the accessibility.

Best regards SLJ.
Feel free to contact me privately if you have something in mind. If you do so, then please send me a mail instead of using the private message on the forum, since I don't check those very often.
Facebook: https://facebook.com/sorenjensen1988
Twitter: https://twitter.com/soerenjensen

2021-04-09 11:37:57

@Slj, that didn't help either.

Thumbs up

2021-04-09 12:25:38

Sorry for cross posting, how to enable TalkBack in USB Debugging? I appreciate any step-by-step instructions.

The past is a foreign country; they do things differently there!

Thumbs up

2021-04-09 20:05:21

@ 7, As soon as I have a correct answer, I'll get back to you.

Thumbs up

2021-04-10 02:12:02

Well, first you have to have a usb cable that can plug to a tv, for example, my tv has a usb-c port that I could use for this purpose. Alternatively, you can use wireless debugging over the network, though that can sometimes be cumbersum to set up, so yeah.
Note: I suppose you have adb installed, as well as the usb drivers for your device as some of them use proprietary things to connect to the debugging sessions, so I recommend you consult your tv's manuals, sites, forums, or whatever for more info.
So, with that out of the way, first you have to have a sighted guide in order to do this, haven't found a way to do it unless, by some miracle, usb debugging is enabled on your box, chances of it happening are practically nill, but anyways.
So, once you turn the thing on, press the home button on the remote. It would be weird for it to not have one, but anyways, press that to go to the home screen.
Once you're there, go to settings. If you don't see developer options there, you have some to go through still, but it's not so paneful. So, once you're in settings, activate the about device option and press select button 7 times on the build number, you'll know if you're pressing the right one, since some text will keep flashing on the screen reminding you you will be a developer soon or something like that. Once a message like you are now a developer! went up in flames on your screen, go back to settings. A new option just appeared in there, sneeky developer options, right?
Now, once you're in there, hit that trackpad for all your worth untill you arrive to the debugging category, then go and hit that usb debugging switch with all the remotes buttons...nah, just kidding.
Anyways, now you enabled the usb debugging, let's make sure it worked, right? So, plug that usb cable in the tv and your computer, then, at a command prompt, type adb devices
Now, in any normal situation, a popup should appear on your tv screen. In that case, check the always allow for this computer, just for convenience, then activate the OK button. At this point, your tv should be able to be issued commands from your computer. To test that, type adb devices in the command window again, it will display your device serial or whatever else your device goes by in this debugging communication. Whatever it might say, if device, in stead of not authorised, is displayed at the end of the output, then you can go forward.
Now, just type this command as given, it sets something like the android equivalent of the windows registry, this version sets the accessibility on, and the talkback service as default accessibility service, because some brands have the accessibility menu for default which, as you could guess, is not accessible at all. So yeah, copy/paste the following command as given in the command prompt, then hit enter to send it to the device.
adb shell settings put secure enabled_accessibility_services com.google.android.marvin.talkback/com.google.android.marvin.talkback.TalkBackService
If you don't hear speech, but earcons are fine, plus someone sighted can confirm that the talkback tutorial is open, either you might not have a tts installed or the one you have doesn't work with your system language. In that case, try installing an engine called eSpeak from the playstore. If that doesn't work or no window appears at all, you might be royally scrued, but write here anyways and I'll try helping as much as I can and know my self.

Thumbs up +1

2021-04-10 09:02:11

@9, I really appreciate your feedback on that. I was struggling to figure out the string I had to use for talkbacm. Had seen everything on the internet regarding the command you provided, but God finding out how talkback was written as a package was hard cause I didn't see anywhere written talkbacm, only Android Accessibility suite.
Since we're here, would this command also enable some other accessibility services such as select to speak or accessibility shortcut?

Thumbs up

2021-04-10 12:24:21

No, it won't, only talkback. In theory those aren't really accessibility services, so I don't think this command could turn them on, perhaps another variation of it, but I think it can be possible. However, your best bet then is to access the talkback settings with the menus, then set up the shortcut your self there. Alternatively, you could use those commands for android accessibility suite too, this way you could have some of them enabled, if, of course the tv manufacturer included it at all.

Thumbs up

2021-04-11 10:59:28

@BGT, So, after doing all what you mentioned on your previous post, I finally got Talkback enabled. It was fulfilling honestly, as there has been nothing that has challenged me, technology-wise, to this point in the last five or so years.
Now, there is another little issue in this process: Talkback is turned on, but I think I should exicute a similar command to turn it off if I need to, as sometimes I might not need Talkback at all, particularly because when I connect it to my laptop through HDMI, and I want to turn volume up or down, talkback just interferes with that, and stops the media playing until it is done saying what it wants. Would there be some way to show the Talkback up on Accessibility menu, since the heading or however it is structured there exists as "visually impaired", but Talkback says disabled, which means that I can't click it. This would be the last command to be issued and then the whole accessibility problem would be solved.
Again, thanks for your help.

Thumbs up

2021-04-11 12:30:58

simply execute this command again, it's practically a toggle tbh. So, if it's on, it will be turned off. For your convenience, the command used to enable and disable it will be pasted below.
adb shell settings put secure enabled_accessibility_services com.android.talkback/com.google.android.marvin.talkback.TalkBackService

Thumbs up

2021-04-11 16:42:12

I thought there was a more practical way that could just make Talkback show up there forever, but this helps too, and I'll keep the command safe somewhere smile

Thumbs up

2021-04-12 10:06:22

Well, after looking up keyboard shortcuts for Talkback, I tried using them on my Android TV, and it appears that by pressing Alt+ctrl+Z, speech can be paused and resumed, which is a good thing!
And yep, I hope someone finds this topic useful in case you face the same issue.

Thumbs up

2021-04-12 15:26:33

i'm glad you could make talkback work on your android tv.
Enjoy

best regards
never give up on what ever you are doing.

2021-04-13 08:52:03

Thanks Ashley, it was really something quite fulfilling to do.

Thumbs up