2018-07-08 05:16:54 (edited by Joseph Westhouse 2018-07-09 20:47:34)

We are excited to announce that A Hero's Call version 1.3 is now available for download. You can update the game by running the updater.exe in your game folder. Please read on for some highlighted changes; as always, a full change log will be downloaded with the update.

Please note that this update may take longer than previous updates to download; please be sure that you allow the updater to finish running before you attempt to launch the game. If you have any trouble updating, or if you have any questions, please email [email protected] Happy adventuring!

Important Note: If you are using a modified keys.config file, please contact us before updating.

What’s New in AHC1.3:
* Don’t Take It Slow: Performance improvements that should resolve issues some users were having with lag, and should also make the game run a bit snappier on all devices.
* Are You In Or Out: We’ve improved the game’s DRM and login to hopefully resolve some inconsistency users were experiencing—no more getting asked to log in over and over!
* A Hero’s Reward: Players who supported our Kickstarter at level 5 or higher will not have access to a cache of unique items to take their adventures to the next level. Once again, we apologize for how delayed this reward is; hopefully, it will provide some fun despite the wait.
* Lurking in the Dark: A new class of enemies now threatens Farhaven’s mines and catacombs. We had hoped to include Ghouls in the game’s release but weren’t satisfied with the sound design—now we’re satisfied, and a little creeped out by them.
* Laying Down the Audio: In response to user feedback, we have added some auditory cues to the quest “Laying Down the Law” which should make it easier to track quest progress, while also making the quest more immersive. Guarding the road north of Farhaven just got a little easier!
*  Update Updates: The game will now alert you upon launching if there is a new version of the game available. This should ensure that as many players as possible are running the latest version, and as an added bonus, you won’t get emails like this for every minor update.
* The Usual Suspects: Version 1.3 also includes added details such as some new map details, two dozen new items, tweaks to enemy AI, and other changes of the sort you can expect in every update, as we seek to make the world of A Hero’s Call as engaging and immersive as possible.

EDIT: If possible, please post general questions or comments on the main AHC thread, and reserve this thread for questions or comments regarding the 1.3 update. This will make it easier for people looking for information in the future to find it efficiently.

Thumbs up +5

2018-07-08 05:26:18

Way cool! Downloading now! Thanks!

Thumbs up +1

2018-07-08 05:33:36

How does the extra item pack work? Do I receive it as soon as I start the game?

Grab my Adventure at C: stages Right here.
You may access my NVDA Remote, Three-D Velocity, Sound RTS, and Road to Rage servers by using the address christopherw.me. Road to Rage uses the default 6789 port.

Thumbs up

2018-07-08 08:33:51

Awesome! I thought the development stopped. But now i see it isn't. Great

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

2018-07-08 09:44:15

Hey Josep!!

I run the update, but when I ran the update. It's just close on me.

Thumbs up

2018-07-08 10:36:26

Awesome news about the update, but sadly, like Dragons before me, I'm experiencing the updater problem, and I also haven't got any emails. Very excited to try the improvements though. Keep up the good work! smile

Thumbs up

2018-07-08 10:50:10

Same issue as above, the updater just closes with no change as far as I can tell and I also received no email. Mostly it closes too quickly but once NVDA read an error, something about Rsync and that it has reached the max number of connections, but it was gone before I could copy it. I haven't been able to get it again unfortunately.

Thumbs up

2018-07-08 12:01:57

hi, i try to update game and when i open updater.exe  and game updated, and when i running a game i see that is a version 1.2.1 i open updater log and see this:
AHCUpdater version 1.1
Waiting for game to close
Downloading files
Removing old files
Update finished

how to update on 1.3?

Thumbs up

2018-07-08 13:41:50

I have the same problem. I ran the updater, wait just a bit and it closed just like it updated the game successfully but after checking the changelog I found out it failed and It logged mistakenly that update is finnished. It didn't log any errors.

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

2018-07-08 14:45:17

after the updater closed I ran the game and got an error.

The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.

I don't have the email with the download link Is there a direct download for 1.3?
Thanks love this game!

Thumbs up

2018-07-08 15:26:24

I also had problems with the updater to where it appeared that nothing happened even though the update log said that the update finished with no errors.

I also got no email about the new update as well.

My solution was to go to the email I got for the update to v1.2.1 and redownload the zip file, then extract it on top of my installed game. Now I have v1.3!

Thumbs up

2018-07-08 15:33:33 (edited by defender 2018-07-08 16:45:41)

LOL Orco you just barely beat me to it.
Though when I did the manual update, I was told their was a new version and to use the updater, so I did and it worked, kind of a roundabout way of getting what I want but either way...
It says it's on 1.3.1 now but the changelog doesn't say anything, so who knows.
Anyway, I have a direct link for you guys.

Here's how to update to 1.3 manually.
Step 1: Download this file.
Step 2: If you don't mind redoing your options and any special keyboard configuration you may have, than simply unzip the file you downloaded directly into your game folder usually found in "C:\Program Files (X86)\a-heros-call" and replace all (don't worry about your saved games, they won't be harmed)
Step 3: If you don't want to deal with setting up your options/keyboard config again, than just go to the "data for RPG" sub folder within the A-heros-call directory, and make copies of the "game.config" and "Key.config" files their.
Put the copies somewhere else, even the main directory is fine, then unzip the file into the "a-heros-call" folder and replace all, after which you can put the "game.config" and "Key.config" files back where they belong, replacing the ones their already with your versions.

If updating doesn't fix your side by side error which it probably won't, than download and install this file.
http://download.microsoft.com/download/ … st_x86.exe

This... -- Is CNN'.
Well Ted, it sure looks like there's been uh, quite a bit of violence around here
"aaoh, that violence was terrible'!"
Yeah it was, pretty bad.

Thumbs up

2018-07-08 16:17:41


I would have posted a link to the zip file too, but I was unsure if that link was considered a private link only for purchasers of the game, so I chose to err on the side of caution.

Thumbs up

2018-07-08 16:29:49

That did the trick. Thanks very much!

Thumbs up

2018-07-08 16:44:39 (edited by defender 2018-07-08 16:46:25)

Nah because your email has to be associated with a payment and you have to unlock the game with your email. So it's not private., and your Welcome CSM, I'm glad it worked.

This... -- Is CNN'.
Well Ted, it sure looks like there's been uh, quite a bit of violence around here
"aaoh, that violence was terrible'!"
Yeah it was, pretty bad.

Thumbs up

2018-07-08 16:58:35

After downloading the file and extracting it and replacing all the items in the game folder, I booted up the game only to find an update waiting for me.
Yes, it's now at version 1.3.1, and the updater now works.
Please note however, that said update takes a long time to complete, so launch the updater and go do something else for about half an hour.
Their's no changelog for this new version, but it's their.
Also, with regards to the reward items, if you supported the kickstarter at level 5 or above, loading any saved game will now cause a message to appear as soon as the game loads into whatever area you were in when you last saved.
Just follow the instructions in the message and find the note in your bag.
Read it and stuf will happen and a mark will be on your map that wasn't their before, then go where the note says to go and use the becon.
Sorry, I'm trying to avoid spoilers...

Thumbs up

2018-07-08 17:02:08

I didn't get an Email either. But we'll see when I run the updater.

You keep using that word. I do not think it means what you think it means.

Thumbs up

2018-07-08 18:10:19

Well, I ended up having to request a new download link so I could get the new one. It asked me to run the updater so I'm just waiting for that to finish. You sure weren't kidding when you said it might take a while LOL.

You keep using that word. I do not think it means what you think it means.

Thumbs up

2018-07-08 18:33:21

Thanks for the awesome update!

Kingdom of Loathing name JB77

Thumbs up

2018-07-08 18:48:26

Grabbing, thanks!

My sskype : mars.bhuntamata, add away buddy. If you think you are crazy, I am as well. I may be even crazier, who knows.

Thumbs up

2018-07-08 19:12:59

Ah! It's been a while since I last played and I forgot that it uses an online DRM.

Thumbs up

2018-07-08 20:38:50 (edited by Naruto 2018-07-08 20:40:01)

still having the same update error it just closes on me, and ive got version 3.0

Blindness isn't a disability, but a diffrent way of seeing things

Thumbs up

2018-07-08 20:42:48

I don't think there is a version 3.0.

You keep using that word. I do not think it means what you think it means.

Thumbs up

2018-07-08 21:36:08

Our apologies to those of you who are having trouble updating. We haven't had this kind of inconsistency from the updater before, and it probably has to do with the size of the update download, which is a result of some changes to the game architecture. For those of you who have not been able to update successfully, your best bet is to either periodically try the updater again until it works, or simply download a clean copy of the game as previously suggested.

A quick addendum to Defender's instructions in #12: version 1.3 includes configurable keys for fast travel, which means that if you are using your old keys.config file in version 1.3, fast travel will not work (hence why we said that if you use a custom key configuration, contact us before updating). You're welcome to use your old keys config file, just add the following line of text somewhere below the line that reads |script_flags:

fast_travel control f

And then edit it to your heart's content, like all the other key commands.

Again, apologies for the inconvenience some of you have experienced. I made a command decision to release the update even with the large download size, rather than taking the time to figure out if we could re-work things so that your download would be smaller, and consequentially less likely to fail; as usual, my eagerness to get you a long-overdue product quickly came with its fair share of downsides, but hopefully you can all get updated and ready to go soon. Please continue to email support if you have any trouble, and thanks for your patience!

Thumbs up

2018-07-08 21:51:08 (edited by Jonnyboy1991 2018-07-08 21:53:45)

Right, downloaded the version of the game from the link above and it told me to run the updater. Yep, done that and still, updater closes. I have no idea of what is going on here. Rsynk, I swear... Lol. Some people are not having problems, but people like me are? Wow? And it even doesn't even stay open for me long enough for me to see the contents of the terminal window.

Edit: Guess I'll keep trying. Lol.

Jonathan Candler, A.K.A, Jonnyboy