2020-06-28 06:11:52

Haven't seen a post about this here, but I wonder if someone hasn't talked to the dev already since there seems to be some strides toward accessibility.

http://fifthaeon.com
Playable CCG with a few unlabelled buttons.
Battlefield looks like this:
Enemy's health, button to view enemy's crypt, enemies played cards.
Your health, your crypt, your cards.
resource collection buttons.
end turn.
your energy.
your hand

There's a tutorial in the game, but I'll explain how to play a round just in case the labeling throws people.

When battle starts, you can select any cards in your hand to replace with a new draw. When a card is selected, below it's information you'll see something like virtual marker. Hit the done button when you're done.

When it's your turn, you can play as many cards as you have energy to play. Energy works like this. You have a total energy cost, which is the top number of any card. So if you see something like this:

4
minotaur
growth/small
growth/small
growth/small
5
4

This means the card takes 4 energy and 3 of the growth resource to play.
Below that are it's health and attack values respectively.
You gain total energy by collecting resources, generally one per turn. You can do this by clicking the growth, renewal, synthesis or decay buttons above the end turn button. One thing that's a little confusing is often when you click one of these, the game will say "You can't play a resource right now." But if your turn just started and you click one of these buttons, you will gain the resource and energy. You can always check by looking at the numbers below the buttons.

When playing a targeted card, the game will tell you that eligible cards have a blue glow. For us, there's an icon that appears that says something like crosshair. If you see this below a card's info after clicking a card that needs a target, you can click on this card to target it.

Battle is simplistic. Before you end your turn, you can select any cards that have not been played this turn, you'll hear a metallic clink sound. Any unit assigned to combat has a crossed-sabers icon below it's card info. Once you hit end turn, you'll see an attack button appear. This means if the enemy has any cards in play that can be attacked, you can now assign specific attackers to these cards by clicking on your attacker, then clicking on the target you want to attack. After that, your creature's attack is simply subtracted from the enemy creature's HP. There may be some effects in game that will modify combat slightly.

When you go to open packs, you'll see 3 unlabelled buttons. The first lets you open a pack if you have one. The second lets you buy a pack for 100 gold. The third takes you back to the main menu.

If you don't know what a button does, often tabbing over it or pressing B to move through the buttons will read a label on the button, if one exists.

Note that I haven't tried this game with NVDA.

Thumbs up +2

2020-06-28 06:50:39 (edited by defender 2020-06-28 06:55:21)

You may be able to use JAWS plus control plus tab to label those unlabeled buttons, and JAWS plus space followed by O followed by C to OCR them if tabbing doesn't read it.
I also find that placemarkers can be useful in these games to skip quickly to relevant text which has changed if the N key doesn't work.  You can set one with control plus shift plus K, and navigate between them with either K and shift plus K, or numbers 7 through 0 on the number row.

Buy the worlds greatest machine gun. It's about 50 inches in length, It's huge! & it can shoot really far, &, it's cheap!
Lets demonstrate this: stand still Thom...
Okay ma.aaa!
Oh! crap!

Thumbs up

2020-06-28 14:00:32

Hello!
i opened the game and i created an accownt there. i can't start playing though. what do i do when it's my turn? the play a resource button is unavalable to press so i don't know what to do. any tips?

don't wish to become like the oceans, flowers, sun. oceans will dry out, flowers will die, and the sun will vanish. be yourself and nothing and no one else and hope for a better tomorrow.

Thumbs up

2020-06-28 15:26:27

yeah I also don't really know how to progress here. It says that the play resource button is unavailable and all the cards i have cant be played. there are four graphics that always say 0 also in here. i tried clicking on them but nothing happens here.

Thumbs up