2020-02-11 08:31:32

I hope Mr. Gomez updates his NVDA Addons page because of the python 3 update.

p As forthe Audio Themes NVDA Addon on, even the curent developer version is not compatible with the newest update yet.
It'll be eventually.
I can safely say though, Jeff's NVDA Addon's site is gonna need a make over!

2020-02-11 08:57:26

That's pity, that Speech mobile isn't compatible. It is better, than onecore.
What should I do? Contacting devs to edit problems with Windows onecore?

Music is the language of the universe.

Thumbs up

2020-02-11 10:07:38

guys I am worried about speech history copy add-on.
where can i find it? or it will know longer works?

Thanks and regards.
Madhusudan
Visit my youtube channel to dive into accessible tech tutorial.
https://www.youtube.com/channel/UCvVJNv … 9wXunGvl9A

2020-02-11 13:24:43

Regarding speech synthesizers, Acapela already has an updated driver on their page for 2019.3, so does Code Factory for their Eloquence/Vocalizer Ad-on.

Tiflotecnia is also working on updates. The Classic vocalizer driver (version 2 that came before Expressive) has already received an update. Strangely enough the English page hasn't been updated but you can download the driver and voices from The portuguese page. I'm using it here and it mostly work great, the premium voices sound OK though the compact voices are experiencing some slight but noticeable stutters.
As far as I know, the Expressive driver is also in process of being ported.

<Insert passage from "The Book Of Chrome" here>

Thumbs up

2020-02-11 13:34:40

Please, where can I get eloquence for 2019.3? Just drop me an email or a tweet.

Your #1 internet trollveloper waz ere.

2020-02-11 13:40:02

I told you of a way on the list Oriol, don't know if you saw it.

Thumbs up

2020-02-11 14:47:53

hi guys कैसे हो

I am a super hero

Thumbs up

2020-02-11 14:56:05

aryamansingh wrote:

hi guys कैसे हो

stop spamming you are so annoying i will report you

What do you call a deer with no eyes?
No idear.

Thumbs up

2020-02-11 15:21:28

@aryamansingh, what's your point of posting unrelated things on the topic over and over again. Perhaps you didn't understand the topic?

Thumbs up

2020-02-11 15:47:08

i think Nvda developpers should have think of this mess.

i demand a ban hammer comes for those thread hijackers btw.

Thumbs up

2020-02-11 16:31:10

Does anyone know where I can get an updated version of the speech history addon?

Thumbs up

2020-02-11 16:40:40

It will soon be officially released as the mentioned pull request was merged.

Thumbs up

2020-02-11 16:51:32 (edited by jack 2020-02-11 16:56:47)

turkce_rap wrote:

I think Nvda developpers should have think of this mess.

As if they haven't already warned users that it would be?
1. Python2.7 is officially at its end of life. Move on.
2. NVDA2019.3 was in desperate need of Python3's new potential as everyone knew. This port was no small weekend project, so don't go assuming it was one and that no thought went into this. Here's something to think about though. Their hard work still isn't your free lunch. Even if you can't donate, you are generally expected to assist the project in however way you can, which can and should be as simple as testing the alphas/betas, contributing feedback, and contacting NVDA addon developers during the months before when you had plenty of time to. Even then, there are genuine concerns about addons, which are definitely justified, indeed I can't upgrade myself because Sibiac, but I have been keeping 2019.3 betas around as portable for who knows how long. When they release these and ask for feedback, they actually, are looking, for feedback. These are people doing the project more or less grant/donation funded, and feedback makes a huge, huge difference. Some people really need to be, not necessarily more grateful, but cut the negligence a bit, i.e. waiting to the absolute last minute tto install 2019.3 instead of testing the betas and reporting this stuff. I don't suppose any of the legitimate complainers have any mission critical stuff to worry about, and even if they did, you literally have nothing to lose with a portable installation.
The, quote, addon mess, is not NVDA's fault. The final release hasn't been out for one freaking week yet. Give it time before saying they should have thought about this mess.

I'm the only adventure at c: master hahahaha I have unlocked just about everything!

Thumbs up +1

2020-02-11 17:15:33

The NVDA developers did think of this. This is one of the reasons why, even though this update was released in 2020, it's called 2019.3. They decided to delay the release so that the majority of the addons could be updated. There are several that are still WIP, but most of the official addons have been updated, with others like speech history being finalized right now.
The one last major holdout from what I'm aware is NVDA Remote, which is actually mostly updated. The problem right now is the developers. Other people did most of the work to port Remote, but now the developers are not communicating with the community to explain what they still need to do, why the update has not been released. NVAccess themselves don't seem to be very happy about this, but Remote isn't their responsibility even if the NVDA devs did do some of the work to port it over. NVAccess should not be responsible for addons that aren't necessary for the core functioning of NVDA. They already have enough to worry about in that regard, possibly more than they can handle. NVDA is still great, but I've noticed a downward spiral since 2018 in performance. I'm hoping that 2019.3 will fix some of these things, and that the modernization will pave the way to fixing more of them.

Sincerely,
Lucas.

Thumbs up +1

2020-02-11 17:20:10

Preserved core functionality with intended add-on updates coupled with a page reflecting the state of said updates? And for free? Hmmm...

2020-02-11 17:44:19

ok, two points here. To those who keep saying that nv access should have thought about add ons not working, no. they didn't have to. Addons are third party programs and thus not the responsibility of nv access to maintain or worry about, they have to worry about enough as it is with the limited funding they run this on. You should stop crying about how little they thought of you and your shiny addons, and show at least some apreciation that you don't have to give $1000 to fs, or $100 every year, just to use a computer like everyone else. One more thing though, I do wonder if there's a way to get the python 3 version of eloquence working properly? Right now, it loves to crash frequently. Does anyone have a version that doesn't crash, or have a workaround for the crashes?

Ich bin 1,95m groß, muskelbepackt, und ein berühmter Rocksänger, der den internationalen Durchbruch jeden Moment schaffen wird. Ich fahre eine schwarze Luxuslimo und kann fast alle gängigen Weinsorten mühelos unterscheiden.
Ach du Scheiße, das glaubt man mir nie...

Thumbs up +1

2020-02-11 17:51:26

Hey Connor. The IBM Driver on Davidacm's Github Page is a better work around for getting Eloquence. It doesn't come with the actual voice files because it's illegal for it to, but as long as you have the voice files it's easy enough to add them in through the settings dialogue. The addon can be found on the page I linked to above in the readme.md.

Signature start:
I don't mind if you disagree with my opinions, but if you're going to dismiss something I say, please explain why you don't agree with me. You don't have to, but it helps me understand you better. I don't like when I write out my thoughts about something and try to make people understand my opinions, only to be told I'm wrong and not be told why someone thinks that.

Thumbs up

2020-02-11 18:40:05

The problem with that thing is that the root dictionary (root.dic) does not get loaded. It's the weirdest thing, and kind of necessary for me because I use a custom one.

Sincerely,
Lucas.

Thumbs up

2020-02-11 19:01:40

I will add a list of addons which are inaccessible with latest version:
emoticons,
translate,
slavic language pack

Thumbs up

2020-02-11 20:44:38

Hi @67, what are these voice files and where do you get them?

Ich bin 1,95m groß, muskelbepackt, und ein berühmter Rocksänger, der den internationalen Durchbruch jeden Moment schaffen wird. Ich fahre eine schwarze Luxuslimo und kann fast alle gängigen Weinsorten mühelos unterscheiden.
Ach du Scheiße, das glaubt man mir nie...

Thumbs up

2020-02-11 20:47:21

@Jack

You can take it as a feedback on NVDA'S project side. Nothing personal. i never said i m not apriciating devs working.

as i always say and thats just my imho, official addon features should be standardised. i agree with you on one thing, i've relied on nvda update  check without reading the site and thats my fault. so happend what happend anyway, hope things get resolved soon.

Thumbs up

2020-02-11 20:48:02

Guys, anyone got latest updated elequence  addon Jaws alike config btw?

Thumbs up

2020-02-11 21:00:55

@69 all of the translation add-ons have been updated. Instant Translate is on the official add-on page, JGT can be found on blindgamers.com, and the other translate add-on by Yanik can be downloaded here

<Insert passage from "The Book Of Chrome" here>

Thumbs up

2020-02-11 21:26:32

Thanks for posting this OP. It prevented me from upgrading to 2019.3 and I came to find out later that Notepad++ isn't supported in the new version which is a showstopper for me. I'm one of those people that upgrades NVDA without checking the change log first.

I did eventually try it out and did notice that NVDA has done their due diligence and noted which add-ons will break in the new version, so if I hadn't seen this post that message in the installer would have stopped me also. But thanks for coming here to post the info and give us a heads-up. For people like me who aren't tuned into social media and things (despite a couple on here saying NVDA hasn't exactly been silent about this breaking change, implying that everyone should have known anyway,) these types of posts are very helpful. I had no idea until I saw this post that 2019.3 is the Python 3 upgrade.

Thumbs up

2020-02-11 22:31:45

@connor142
The voice files that @Dan_Gero are talking about are the IBM ViaVoice TTS language/voice files. If you recall, ViaVoice TTS is basically a repackaged/rebranded version of Eloquence, so to speak. The easiest/legal way of obtaining the files are to either get a trial version of IBM HomePage Reader or searching for the actual ViaVoice speech recognition software either on a CD or download. But, since the TTS is basically Eloquence, the DLL file and the actual voice files should work (you can just use the Eloquence files from anything with Eloquence, as long as it has ECI.DLL, or in the case of IBM TTS, IBMECI.DLL).

Thumbs up