2018-12-15 18:10:16 (edited by queenslight 2019-01-07 20:41:45)

Introduction

Greetings everyone!

By blessings from the creators of Jenni OS/Nash Central, I bring to this "nerdy" community, the "Next Jeneration" (misspelling intended,) of "Jenux OS" to the general public! The creation of said OS is done by Daniel Nash himself, and is powered by the Arch Linux Operating System.

Disclaimer: Jenux has absolutely "NO AFFILIATION" with the Talking Arch project.

Downloading & Installing

NB.  If you'd like to grab the latest .ISO of Jenux instead off the VM below, grab that from right here

  • Download and install the latest versions of VirtualBox and by "extension" (pun intended,) grab the "Virtual Extension Pack" from the same link above, as it is "REQUIRED" for all "drivers" to work properly, especially for "USB t.0" and later.

    NB. If having trouble with the Extension Pack License Agreement screen, press the down arow around 10 times, press the "Space Bar," then tab or press Alt-A" to "Accept" said agreement.

  • Grab the "Open Virtual Appliance" file for Jenux itself direct from Nash Central, right here , and wait for the 7.5 GB file (at time of writing,) to download.

  • Press enter on the "jenux.ova" file ya downloaded, and follow the prompts.

Starter Up!

Since this is AG Net after all, most off yall should know how to get up and running with things. But if not, simply entering/copying

VirtualBox VMs/jenux/jenux.vbox

into the "Windows-R" (Run Dilog,) shall get ya up and running.
Alternatively, you can start VirtualBox the normal way, bring up the context menu while within your virtual machines tree, then choose the option to create a shortcut to said VM on the desktop.

Once the machine starts, your username and password, are both default

jenux

with "NO CAPITALS" applied.

Once loged in, you'll be taken to the "Mate Advanced Traditional Environment" desktop, where if ya love those clasic days of the "Windows Start Menu," you'll feel right at home.

By default, Orca uses the "laptop" layout, with the "capslock" modifier, referred to as the "Orca" key. You can press "Orca+H" for keyboard learnning/help, or press "Orca+Space" for the "Orca Preferences"screen.

The voice you hear by default, is provided by "RH TTS," a speech system similar to "Speech Hub/Open Mary," though does not need Java on the system in order for said voices to work.
Besides the RH TTS voices, other Text-To-Speech synths which come along with Jenux include:

  • Pico

  • Flite

  • ESPeak (The "ORIGINAL" version, not "Next Gen.")

Notice that most voices (particularly "Espeak,") have a more "extensive" list to them," unlike most Linux distros out there.

Speaking of the voices, notice that everything's setup in similar to how a certain screen reader on Windows works? On most Linux systems, Orca does not give you said info out of the box. O course, customize it all to your hearts content!

Exploration!

I am leaving you, the reader, to explore most of what Jenux has to offer on your own. But since this is a "gaming community" after all...

1. If you enjoy "Sound RTS," the "Games" menu is your friend.
2. The following two phrases will sum up everything:

sudo pacman -S freedos-accessible

and

"Personal Computer Systems"

NB. Any console-terminal screen reader will do, for playing said DOS games.

Shutter Down!

Again, this is the "AG Net" community here, so folks should know how to shut down/save the state of your machine. I will however, mention the key strokes you can press while at the "Close VM" screen (invoked with "ctrl+q" by default,) considering most screen readers don't read said popup window.

  • Alt+E = Send shut down signal to the VM, thus showing the traditional shut down screen.

  • Alt+S = Save the current machine state, to pick up from where ya left off.

  • Alt+P = Power off the machine immediately.

Conclusion

And with that, enjoy!

PS. In case folks haven't figured it out yet, I take no credit for anything belonging to the Jenux project/the Jenni OS's site. That's all Daniel and crew, I'm just promoting!

2018-12-15 18:29:25

holy shit, move over vinux! you even included sound rts and the Free Dos software.

watch my brother's twitch stream here:
https://www.twitch.tv/sylvrexe

2018-12-15 18:51:30

@2

Yep? I kid ya not. Its all there!
BTW, fixed the link for downloading Virtualbox/the extension pack.

2018-12-15 19:00:11

That sounds freaking awesome, have to try it with vmware tough.
smile I think it will work.

I am your friend, your spam bot reporter, I am what ever do you wan a be to you, but if it is not good, I will not be!
And please, give me a tumbsup, it makes me happy to see one.
Thanks.
Angel Productions, the producer of nothing :)

Thumbs up

2018-12-15 19:51:52

Here is the webpage for this thing for those who want more info before just randomly downloading things.
https://jennios.com/projects.html

2018-12-15 19:52:33

@4
The lastt time i tried it with VMWare, it didn't want to unpack properly. Good luck with that though...

2018-12-15 19:57:06

@5

I was originally going to add said info in post 1 originally, however since the file on the site isn't the latest yet, best I wait.

2018-12-15 20:12:30

I love this thing. I used Jenux prior to the VM being released, and now you can try it out.
Note: If you want to install the same build on your machine, at the installation menu, type L (or use the arrow keys to select the "Install Jenux" option), then when it asks you what system you want, select Mate by pressing M (or again, using your arrows to select the Mate option.)
The Jenux ISO can also be used to install Android, and one of the Jenux builds includes Kodi, ready to go! Then, of course, there's the everything build, which gives you exactly what it says on the tin.

Thumbs up

2018-12-15 21:30:57

Wow, this is interesting.
I am vary close to updating my workstation.
Once I am used to it I plan to convert this old 4 year old toshiba i5 3200 unit to a linux box.
I have used sonar gnu before and vinux and was thinking about either going with sonar because its loaded with everything or ubuntu mate.
What desktops does genux support.
As to the freedos thing, I would need a screenreader that would play through soundcard.
I used linux when at university ages ago.
Since then while yes I could use a vm, I would really like to use it on a system, sadly while yes I do have that sort of system, I have never really gotten into that.

Thumbs up

2018-12-15 21:44:46 (edited by Chris 2018-12-15 21:45:18)

This sounds really interesting. Can I install this on my 2006 Mac Mini if I burn the image to a DVD or would it let me boot via USB?

Grab my Adventure at C: stages Right here.

Thumbs up

2018-12-15 21:46:54

@9

Sonar GNU/Linux, has been no more as of last year, since of a fall out which occurred with the Vinux team. The latest version of Vinux v5.1, sadly is still on Ubuntu 14.04 (which will soon be at "End Of Life."

As for Jenux in ISO form, you can grab the latest for that, over here , which was made on the 24th of September 2018.

On both the ISO and VM, I should have mentioned, "Wine" is also on there. Thus, how ya think the "FreeDOS" package is working? smile

Lastly, as I ntioned in post 1, its using the "Mate Advanced Traditional Environment." Should I just say "Mate Desktop" instead from now on? wink

2018-12-15 21:52:13

@10

As Daniel Nashtold me himself on the 14th of December in the late evening, the best Linux box anywhere, is a Macintosh.

I must say though, GPD Win, also works wonders!
I can safely  say however, with this Dell Venue 11 Pro, Jenux in a VM runs very well!

2018-12-15 22:03:46

Okay, that's great. My Mac Mini has an Intel core Duo processor and 1 GB of RAM. Can I create a bootable USB drive using Rufus or must I burn it to a DVD?

Grab my Adventure at C: stages Right here.

Thumbs up

2018-12-15 22:50:29

Hi, Daniel Nash here. As far as I have tested, you can use either a dvd or usb to propperly boot the installer. However, some machines need the iso to be raw written, for example using rufus' dd mode. Also, for the freedos accessible package, you do not have to worry about sound card issues, since it's just a qemu image with curses display, meaning that you use either orca's flat review or your console screen reader of choice to read the dos console and prompts. Queenslight, you are correct that wine is included, but that is mainly used for running self-voicing games like audio quake, swamp, most bgt games if you get rid of the nvda controler client, the kitchensinc stuff, and a number of other self voicing applications.

2018-12-15 23:32:19

I've tried burning the disk image to my USB drive using both ISO mode and DD, but it doesn't work. I plug the drive into my Mac, turn it on, press and hold option, press right arrow and hit enter, but the machine boots into Leopard. I also tried pressing and holding u and c while booting, but nothing helps. Do I need to use a DVD? Also, why is the image only 800 MB or so? Is that normal?

Grab my Adventure at C: stages Right here.

Thumbs up

2018-12-16 00:01:40

the reason that the immage is only around 800 mb is because its a minimal installer that goes out into the world wide web to get the files you need once you chose your configuration. if that wern't the case, umm, well, the iso would be super huge, and prob wouldn't even fit on most USB's

R.I.P Melinda Cook.

2018-12-16 01:54:40

Hi. @15: Your machine may be using a 32-bit uefi firmware implementation, which is not directly supported by systemd-boot. If you can, try burning to a DVD and holding down c while the machine boots to boot using isolinux, the CSM bootloader. Once the machine boots into the installation environment, the installer will make the target disk bootable on CSM, 32-bit and 64-bit uefi environments. Hth

2018-12-16 01:58:47

One thing that Nash and Ernie failed to mension is that Jenux supports Mate, Gnome, and Rat-poison (although that's more of a window manager). You can also install whatever desktop you want with pacman -S whatever. The base system is for those like myself who just love the command line and don't need no fandangled GUI.

Thumbs up

2018-12-16 06:41:19 (edited by Chris 2018-12-16 06:59:21)

I burned the disk image to a DVD. However, the Mac Mini ejects the disk from the slot after about a minute. I've tried turning on the computer and holding c for a few seconds, but the disk is always spit out. Any ideas?

edit

I tried booting the disk from my Dell latitude and managed to get Seeing AI to read a bunch of jibberish. I could make out lightweight Linux, so I assume the disk was loaded. However, I didn't hear any speech. Does this not come up talking with Orca? If so, how do I enable the screen reader? Why isn't my Mac booting from the DVD?

Grab my Adventure at C: stages Right here.

Thumbs up

2018-12-16 10:00:47

@19

The start up with Jenux, is similar to how Debian does it with their Network/DVD installs vs the "Live" CD/DVD.

If talkin does not occur after 60 seconds, simply hit the enter key once or twice, and it shall come up speaking with the Jenux menu.
BTW, its using "Speakup" at the start, not "Orca," although Orca will come up speaking after you log in to the system.

2018-12-16 16:48:58

I pressed enter a couple of times after letting the machine sit for a minute and heard the disk drive spin up. After a little more time, I hear beeping noises followed by a chime, but no speech. Seeing AI informs me there are options to install Android, and other things that I can't make out. I even tried using a USB sound card, but no go. I don't want to press enter too many times just in case I overwrite my Windows partition or do something else undesirable. Why don't I get speech? Any ideas on why the Mac won't accept the disk? It seems to be working properly aside from the no speech issue.

Grab my Adventure at C: stages Right here.

Thumbs up

2018-12-16 21:01:13

Hi, what is happening here is that the installer booted successfully, but the chime and beep sequence means that it is waiting for you to select a sound card. To do so, wait until you hear the long 440HZ beep out of the sound card you would like to use for speech during the installation and press enter. If you missed that point, type option s at the menu to move the highlight to drop to system shell, hit enter, and type pick-a-card. This will replay the beep sequence sound card selection pro,pt. Once this is done and your sound card is selected, type talk-to-me, which will restore speech through your selected sound device. To get back to the menu, hit control d. Hth

2018-12-16 21:27:54

Hi,

Maybe slightly unrelated, but are there any good guides on how to setup orca and such on arch? I can install the packages, but usually won't get speech and am not sure on how to fix it.

Roel
golfing in the kitchen

Thumbs up

2018-12-16 21:31:55 (edited by Chris 2018-12-16 21:32:46)

Thank you for those instructions. Those were very helpful and should be written down on the website. Now I'm confused. There are a bunch of different options to install Android, install to a Raspberry Pi, etc. Does this distro run on the Raspberry Pi with all the applications and speech? Also, what is the Android option? What version of Android is this?

Now that I know the disk works properly, does anyone know how to make it work with my 2006 Mac Mini? If I get it to work, can I use the built-in sound card and will it work with the built-in Wi-Fi? It's not really convenient for me to connect an RJ45 cable because the router/modem combo is in a really awkward space.

Grab my Adventure at C: stages Right here.

Thumbs up

2018-12-16 21:37:55

Hi, this all depends on how you installed your graphical environment. For gnome, just ensure gnome is started through startx or gdm, and hit alt windows s, after which you should hear "screen reader on". For mate and other environments where this does not work, hit alt f2 in mate or gnome, type in killall speech-dispatcher, hit enter, and do the alt windows s command, or after running killall speech-dispatcher, hit alt f2 again and put in orca --replace. If using xinit to start your X environment, before using startx to bring up your environment, add the following to your shell initialization file:
export GTK_MODULES=gail:atk-bridge
This will also fix orca starting without reading anything if your chosen DE does not use a GTK file manager. If using a QT based desktop, install qt-at-spi and add
export QT_ACCESSIBILITY=1
to your shell initialization file, above startx. Hth