2021-02-18 02:56:05

Hello.
I use Vmware and I found that there are problems using Linux there.
For example, Ubuntu Installer is not accessible with Orca. But it works if I try it on a real machine.
Can I work with Vmware, or should I use Virtualbox or other options?
Thanks in advance!

Thumbs up

2021-02-18 03:08:35

Vmware should work fine with Orca.  I've got 2 vms on my machine currently that I use for various dev stuff, and both have working audio out of the box including at install time.  Go into the device settings for your vm and make sure that the audio settings are configured to give it an audio device.

Your biggest problem will be latency, but you can fix that by getting a USB audio interface, plugging your headphones into it, and telling VMWare to connect it to the guest.

My Blog
Twitter: @camlorn38

2021-02-18 04:12:10

Omg really? I've vurtualized linux loads of times, and the only problems are the latest installers which also give trouble on bare metal.

Join me in eliminating BGT from the forum.
It's very easy, if you see a topic about BGT, simply don't reply to it.
If you're thinking about creating a topic about BGT, just don't.
Doing these things will cause all such topics to sink to oblivion.

Thumbs up

2021-02-18 05:44:58

When I run Ubuntu 20.04 installer on a real machine, Orca reads all windows. When I run on Vmware, it reads Install as superuser and that's it.

Thumbs up

2021-02-18 15:01:08

it always works for me...

best regards
never give up on what ever you are doing.

2021-02-18 16:40:32

well, it's vmware's fault, I tell thy. So, it's something called easy install, or unattended install or something, don't remember the name off the top of my head. So, what it basically does is it automates installation for you, thing which you might not like, for...hmm...understandable reasons. One thing you can do is, when selecting the OS to be installed on the vm, check the radiobutton that says I will install the operating system later. I don't exactly know where the option is, as I am using virtualbox now, but still...

Thumbs up

2021-02-18 17:02:22

@bgt lover
I know of the auto install feature and I'm not using that.
I have an Ubuntu 20.04 image. I'm creating a new virtual machine with no automatic installation. When I start Orca it reads "Install as superuser" and that's it.
If I load the same image on a real machine, Orca reads the installation window.

Thumbs up

2021-02-18 17:30:08

I doeno, it worked with the auto install for me just fine. granted, it was ubuntu 15.

I lost a friend. but I am willing to start over.
if you wanna add me on discord, it's tom_riddle#1416

2021-02-18 17:31:20

hmm, weird, on virtualbox it works. Maybe try doing ocr on that window to see if the thing actually shows anything on screen?

Thumbs up

2021-02-18 19:00:15

You should also be able to fix a lot of the latency by installing VMWare Tools in the guest machine.

If you for whatever reason wish to contact me, the best way to do so is through Discord (Minionslayer#7549). You'll get the quickest response times, and by extension, a higher priority. I also sometimes post my thoughts (for the better or worse) over on Twitter at @Minionslayer2.

2021-02-19 08:07:16

I use virtual box... it works a bit better for me.

best regards
never give up on what ever you are doing.

2021-02-19 08:55:22

@ashleygrobler04
As I remember, there were no such problems with Virtualbox. But I can't install Debian on Virtualbox.

Thumbs up

2021-02-19 09:08:57

why not? I think there was a problem with the language selection screen and a crash present in the older versions of virtualbox, but I also herd it will be fixed, so I imagine it might be done, so it might be already.

Thumbs up