2018-08-09 05:34:32

Any updates on that documentation Oriol?

Buy the worlds greatest machine gun. It's about 50 inches in length, It's huge! & it can shoot really far, &, it's cheap!
Lets demonstrate this: stand still Thom...
Okay ma.aaa!
Oh! crap!

Thumbs up

2018-12-14 00:57:38

I have a problem. After resetting Beatstar, It stops working. After selecting language nothing happened and program stopped to work. Please, could You fix this issue?
Also, before that after redownloading new version It says, that there is also new version, but this version isn't in the server.
Please, could You look on this problem?

Music is the language of the universe.

Thumbs up

2018-12-14 01:48:30

Ok, I have no exact answer to your question, but my experience is kinda similar to yours, so I'll try to describe it.
I've downloaded version 4.0, first, of course, simply to update the game, but also because I was experiencing that nasty downloading issue that was allready mentionned by many of us.
After having downloaded version 4 and replaced the folder, I've tried to run the game. I do hae access to the new options (menu structure and mini games), but it still indicates that I'm running version 3.5. So I've tried to look for all the traces of the old version, meaning to delete them all. I found one folder in app data containing the packs, one in roaming containing game files, and one data file in my documents (maybe I'm responsible for that one but I'm not sure). Anyway I managed to destroy that all. But... but even if the soundpacks are indead suppressed, 1. the game still tells me that I'm running version 3.5, 2. the downloading bug is still present.
I really like this game, don't get me wrong, but it's becomming quite anoying . Most of my soundpacks are corrupted for having only been partially downloaded because of this bug, and updating the game doesn't seem so easy ... So if you have any suggestion, don't hesitate!

Best regard,

Thumbs up

2019-03-12 15:09:57 (edited by The Imaginatrix 2019-03-12 15:17:27)

I was playing the latest version of Beatstar, and completed a pack, but the end theme was kind of long, so I pressed enter to skip it.

And I just lost 400k + beatcoins I'd been saving up. So much for getting back into Beatstar.

Edit: To clarify, what happened was before I started the pack, I had about 400k beatcoins, probably slightly less, as I had bought 75 safeguards before starting. I completed the pack only using about 20 of these safeguards, and then there was the long victory theme and I pressed enter. When I went to check how much I now had, it said "Null beatcoins", and I went to the "buy safeguards" screen and it confirmed I now had zero beatcoins. I went to another pack and earned 12k beatcoins, and that is currently all I have. Do you guys have. Any idea. How long. It took me. To raise. Over 400k. Beatcoins? Hint: It was a friggling long time.

Thumbs up

2019-03-17 09:14:34

lool probably bug.

love is nice. If someone is against of it, don't listen to them. You must listen to your heart

Thumbs up

2019-03-17 10:20:29

You probably stopped the game before the  beatcoin sounds stopped playing.
So that corrupted your save file.
I'm sorry this happened to you, and I am currently facing some issues with beatstar's current code, that's why there haven't been any new versions. Basically, the new versions of electron don't support the encryption model that the save files are currently using, so I'm making an online solution to convert your save files.

Again, sorry this happened to you. beatstar is my first js game, and there are still some things I could have done differently in the code.
I am sorry users are having so many issues.

Thumbs up