2017-12-14 07:52:42


Long rant below. My apologies in advance.

I am playing this game on a iPhone 6, running os 11 with all the updates. I have nothing running that shows up in the app switcher.

just in case you did not know, a new release came out this week. and I am here to post my comments on it.

now in my situation I am near resetting, but not quite there yet. I have 8 quests, one of which is 5000 automations and only got 3700 of that done so far. so out of the other 7 quests at the time of the update I had 3 left to do. Those being:

1 million logs. Of which I only needed to sell 90k more. so I ran 3 production slots to finish that off.

I need to sell 150k wool and 350k clothes. I have 33 slots in the farm producing the wool I need. And I have 93 slots in workshop to produce the clothes.

so seeing the change log for this update I was elated. It is very difficult working with the workshop's 93  slots. I could only work in there if absolutely no slots was running or the storage was full.

I am extremely disappointed with this update and I will tell you why. but in the future, to me and my suggestion to all, is to never update in the middle.
Work until your ready to reset. Then update. or reset your game then update, but do not do it in the middle.

here is a look at the change log and my comments:

1. Improved performance in locations with many production slots

my opinion is that its far worse after the update,  not better. As I mentioned I have 33 slots in farm, 93 slots in workshop. After fiddling around with it for a brief period of time opening, closing, and even restarting my phone, I was able to select the restart all button to get them to start producing. But just to open those locations took longer than before. now normally I use voice over but that seemed to be highly non responsive in the workshop. I had to turn on the accessibility voice to maneuver round in there. but no way I would be able to select a production slot and do anything to it. but eventually I did get those to start producing. So I went over to the lumber yard to turn on 3 slots. Nope. couldn't do it. had to wait till my storage was full then I was able to select just those 3 slots to start producing. What a nightmare.

2. new options in the setting menu

No comment needed here.

3. Save game to cloud

good option to have. have not tested it to see if it works or not.

4. fixed rare occurrence where selling were selling in the city does not work

I don't think I have ever encountered this. There has been times I have sold products and it does not tell me how much gold it made. But that's all.

5. fixed where some quests were not showing up in the reset screening some languages

Never noticed anything like this in English so no comment here.

6. build number shows on main screen

nice to know.

7. number formatting improved for voice output

yippee! The numbers read like their supposed to now. This is a very good thing. Appreciated.

So overall I rate this update a 2 out of 5. its sluggish and the most notable improvement of working with areas with large production slots falls way short of its expected goal.
Before I started to write this, I had almost 2 billion gold. around this point I take my 4 boosts, put on real estate mogul, and go buy some production slots. After setting those 4 boosts I was off. I started in the lumber yard. After tapping twice on it, it opened. but to move in there was non existent. It jumped around at its free will. I would swipe down and end up jumping about 3 or so times before it stopped. but usually this took 10 or more seconds for me to even get a voice output as to what it was doing. if I switched to the accessibility voice I could some what move normally. Finally got down to the bottom but you think I could double tap on the buy production button? If you said yes your wrong. I tapped like 50 times and could not get it to buy a slot. And if I switch back to voice over it seemed like it was locked up. It wasn't until 35 minutes later and another reboot of my phone before I could purchase the slots And also by this time my storage was full so I think that had something to do with it also.

now for a pre-update gripe. I have noticed the occurrence of this happening has increased lately. And the only common denominator is the workshop. I noticed it before when I had to sell 1 million clothes and 1 million fabric. but now having to sell 2 million clothes it seems to have occurred more times than before.

What happens is the game will lock up. then if you check all boosts are done. All production slots have run out of time, and your storage is full. Quite a few times I have started the workshop first. Because if I start the farm it makes it so much harder to start the workshop. then I go and start the farm. after I set up my 4 boosts to work on 1 loom and 3 master worker. some time after doing all that I may check something and it locks up and kicks me out,or the storage is full instantly and all slots are done running. so have to go back thru and do everything all over again.

And twice I have noticed where I am not doing anything at all,, but the game is open. the phone is just sitting there and the next thing I hear is the home screen. The game is totally closed. I open it back up and enter thru the main screen only to find everything has finished.

Also it would be very nice to have a change log posted here so when folks see that they know a new update has been released.

Overall, I am happy with the game. but certainly not a fan of this latest update. To me its two steps backwards.


Thumbs up +1

2018-05-14 16:17:37

Hi, i am posting a surgestion here:
Will it be possible for the dev of the game to add like a facebook store where you can bye items from your facebook friends like logs wool and so on?
as i said, just a surgestion.
best regards to all!

best regards
never give up on what ever you are doing.

2018-05-14 22:28:09

please fix the bugs,  and how do i get my money back, you did told me uninstal and reinstal again,  the bugs will gone,  but apparently my purchase is gone away,  and save file!
would i replay that garbage again?
why you not listening our feedback
or would i watch the your spyware billions of ads,  i don't care your ads volunteered rewards,  go fix your bugs
and give me back my purchased boost slots,  in real money
i am not talking about game money
been played the months,  and you told me bugs will be fix if you remove and reinstal...  anyways i am done with that garbage

Wish You Best Gaming All!

Thumbs up

2018-05-15 14:57:19

@378, it is not garbage, many people like this game.
and there is not reeally a way that you could get an in app purchase back from a game when it is not a sepperate app!

best regards
never give up on what ever you are doing.

2018-05-15 19:44:08

Hi! It's realy nice game! Thanks!

Regards, Adil.

Thumbs up

2018-05-16 09:50:00

Hello again!
I tried to play this game and I had offers.
First, in the game settings, add confirmation of choice, purchase and so on. And it turns out that I accidentally touch the screen and buy something that I don't need.
Secondly, add gestures to move to the beginning and the end of the list.
Third, after watching the video to activate bonuses, the number of gold coins is not announced, the Back button is lost and the information panel disappears altogether. Correct this mistake, please.
I hope that my proposals will be taken into account!
But in general, the game, as I said yesterday, is excellent!

Regards, Adil.

Thumbs up

2018-05-16 13:37:44

@378, don't say it's a garbage only cause of your falt.

flawless victory!

2018-05-16 15:13:42

@378, For a one-time in-app purchase like the boosts just attempt to purchase it again and you will get a message that you already own this and can get it again for free. This works with both apps and in-app purchases with the exception of something that is considered a multiple purchase like extra lives in a game.

2018-08-03 18:14:37 (edited by wp85 2018-08-03 18:21:38)

I got this game a few days ago, and so far I am liking it a lot.Its the first game I've played on an android, or any smart phone for that matter, wow what I've been missing out on by not having a smart phone before now! lol Does this game have a facebook page? I would like to share it with some of my sited friends. Can sited individuals play the game as well?

Audio game king

Thumbs up

2018-08-03 19:37:33

i very like this game

2018-08-04 11:39:15

hi, this game does not have a facebook page that i know of, but i do know that it has some graphics so that sighted people can see and play the game just like us blind people. so they can deffenetly join you!

best regards
never give up on what ever you are doing.

2018-08-04 14:27:17

It's very graphical, which is what I like, because other developers can realize that to make a game accessible, you don't need to cripple it graphically.

One of the best gifts on this earth is the unconditional love of an animal

It is pure, free of judgement, and raises me to the utter height of glory.

Thumbs up

2018-09-27 06:09:58

hi folks,
First off I would like to apologize. I went back in and checked.there is a cancel button in every production area. So I just missed the one I could not find in the jewelry  store that i reported earlier as being missing.

Just wondering:

1. How many levels are there now to the estate? I am at level 11 and was going to expand it but didn't want to finish off the game. still got a load of stuff to make 5 million of.

2. is it possible to have sounds for every production item? Right now seems like only about half the items have sounds. Specific sounds for each item would sure add a lot more to the game than just the simple ordinary generic sound that most of the items have.



Thumbs up

2018-12-04 12:27:29

Hmm. not many posts here lately.

So I was wondering:

1. How does one unlock something? Never had any problem before. I have tried twice to unlock diamonds, food, and armor. I go to it and unlock it with how much gold it needs. the game says I have unlocked it. But yet when i reset and its not there i have spent the 1 gem to have another quest selected. gone all the way thru them until the original quest returns  an it does not show up. so very curious on that one.

2. how many quests should one have available to do? Before it used to be 8. now I only have 5. Four production ones and that darn 10000 automations one. nice thing is I only need to do less than 700 more to get rid of it.

thanks. happy gaming.


Thumbs up

2018-12-05 02:08:27

hi all i love this gam how ever the gem shop is nto working i can't buy gems only obtain them through watching adds is anyone having this problem to? that's a hole 100 storage i am unable to obtian?

Thumbs up

2018-12-05 11:04:30

I've never tried to buy gems from the shop, I just get them from the video rewards. Looking forward to the next update! smile
Also never had a problem unlocking anything as of yet, but you're way beyond where I'm at Sherm. lol
10k automations? gah! wow! Rock on there, that's amazing!

Thumbs up

2018-12-06 14:16:17

hey all.
I had the game thingy before, but it no longer appears on my play store results. How should I search it? it really rocked for me and I want to play it again.
Best regards,

Thumbs up

2018-12-07 07:27:06

Well... got good news and bad news.

First the good news. I just reset but before I did i unlocked diamonds, food, and armor again. When I went back in there was the first quest for 1000 diamonds. yippee!

Now for the bad news. I wanted to see if anything else got unlocked. so I paid the 1 gem to see what else there was. now i cannot get back the diamonds. Drats.

oh well. at least now I know they got unlocked an maybe 1 or boht of the other 2 will show up eventually.

Nice thing is I only have to do 186 more automation to get that darn 10000 automations quest gone. again, Yippee!

Happy gaming.


Thumbs up

2018-12-29 07:36:05

got some things that are puzzling me and wanted to ask about.

1. The production areas. When just starting fresh you slide from left to right and see lumber yard, farm, quarry, furnace, blacksmith. mine, workshop and lastly jewelry store. but why is it if you purchase either the blacksmith or mine it does not change the sequence. But buy both and the blacksmith and mine swap places?

2. when it pertains to the list of available boosts. Why is it that most items that boost one production by a plus 1 and the boost that boosts production speed are next to each other. The exception being for the lumber yard and farm. For the lumber yard I see sharpened axe, but next is salesman, and then its followed by master lumberjack. Why is salesman in the middle there?

Then before the farm items there  is real-estate mogul. Then for farm it has animal whisperer, followed by quick study, and lastly master farmer. Why is quick study in between those 2?

3. When it comes to the list of quests. Why are they not listed in the order of the production areas? It seems to me that mined items were listed before the furnace if I remember correctly. Not exactly sure if there was any others as I am way past that now. but do know that now it lists the jewelry store items before the workshop. I have pots listed before food.

4. In the city, the way it lists those items there do not conform to the way it shows the production areas. I just reset so do not have specific examples. but do think their listed incorrectly as the quests are listed.

5. So I find a treasure chest and open it. I get a gem. Do wish it would not take focus from where it is to the gem shop. That is so annoying.

Does anyone know how many levels there are to the estate? and if you max it doesn't that finish the game? Or can you still produce stuff?

just some things I was wondering about.

Thanks. Happy gaming.


Thumbs up