2018-10-04 03:06:02

One more: That was on mobile FB, it seems to work great on regular FB? Not sure though.....gonna try mobile FB again but regular FB work but ain't too easy to use

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-04 20:18:50

Hi JaceK,

The option you should be seeing is a game over option. The options normally appear when you scroll to the bottom of the conversation and appear as buttons. I know both Darren and Caccio are playing the game, so maybe they can help out.

Thumbs up

2018-10-04 20:42:13

Yes, by all means use mobile FB, the normal one sucks, not only for this game, but in general for us screen reader users.
(at least I have serious troubles using it, so I only use the mobile version lately)

As for Text Spaced, just in short:
It became my number 1 favorite game, and I am spending literarily almost all of my vast spare time with it.
It features everything I ever wanted and liked in space genre games, and am extremely delighted for finally being able to play such a game, one which I was dreaming about even during my sighted period!

And being able to play it blind, without any significant hinderances or handicaps...no, I just cannot stop playing it, ever since I started, (round 4 days ago), I got seriously, dangerously addicted to it!

Thumbs up

2018-10-04 20:47:58

If any of you have problems playing it, please PM me here, I shall gladly help.
Not that I am that much experienced at screen reader usage, but since even I can play the game without any significant issues, nor even delays, I can probably be of help to other, more experienced screen reader users too in this case!

Now back to the game, and also to its chats on Discord, which provide me just as much fun and entertainment as the game itself!

Thumbs up

2018-10-05 02:41:01

Well for me, there are no buttons, nothing on mobile FB. I simply get options: and nothing more on mobile FB on latest Firefox and Chrome here, using the mobile FB version and mobile Messenger.com ones. I've tried both browsers in regular FB and that shos the buttns up fine, but mobile FB breaks everything here. Ideas?

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 07:23:18 (edited by Caccio72 2018-10-05 07:24:58)

Ok Jacek, let's 1st determine, what differes between the case of the 2 of us, so the result may provide us with a clue.

What platform and system are you using?

I am using a desktop PC, (a quite strong and fast one), with windows 10 operating system.

As second, what screen reader are you using?
I am using NVDA.

And as 3rd, have you actually started the game already?
I mean, its very start was a bit rough for me too, the part when selecting your character and faction, there weren't any buttons, but hitting enter on the options worked. This just made me worry for a moment, but after the game actually started, buttons appeared for each single option and choice.

BTW I just encountered a similar case in another game lately, Torn City, when someone with the same configuration as mine, and even with the same screen reader could play the game just fine, while I had a similar problem to yours, often there appeared no buttons, and I couldn't activate none of those options, menues, selections then.

Thumbs up

2018-10-05 11:34:36

i haven't tried the mobile messenger just messenger.com what's the address for it?

Thumbs up

2018-10-05 11:43:40

I got two laptops and a desktop, two running Linux with Orca, one with Windows with NVDA. All are running Firefox and Chrome.

The only common thing is all are running mobile FB at m.facebook.org

I can start the game fine by sending a mesage. HOwever. Mobile FB does not, at all, across two different OSes and three browsers and vastly differing hardware, display any buttons on mobile FB. I even tested on a tablet, Android tablet on mobile FB with the exact same result. It merely hangs with no buttons and jumping to the next buton on mobile FB jumps tot he 'send' mobile FB button.

It works fine on regular FB however. So. Textspaced, can you guys look into it? It isn't that hard to replicate, just make a throwaway FB account and start the game via mobile FB, it does not display any buttons, elements or anything in the mobile version. This has absolutely nothing to do with screenreaders or OSes, since this is a game that runs solely on FB's platform, that's not exactly a relevant discussion point when across al the devices I've tried, the exact same isue occurs with mobile FB. I've tried on Win10, Android and Linux. The exact same issue persists across Firefox, Chrome, and the stock Android browser.

1. Fire up browser of choice and log in oto mobile FB at m.facebook.com

2. Go to FB messages and select the Textspaced bot in the convo list

3. EIther start a game or carry on an existing game. Wait till you get to a point where you need a button, e.g. setting up your character. THe game wil hang with no buttons in mobile FB in the chat messages.

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 13:08:28

Hi JaceK,

I’ve not been able to replicate this issue. What part of the game are you in?

Thumbs up

2018-10-05 13:31:53

the address you gave doesn't work. can you write it properly please

Thumbs up

2018-10-05 13:50:34

It happens at any part of the game, Textspaced. I've tried with the very latest Firefox. I've tried Waterfox. I've tried Chrome, Chromium and all have the same issue, all being up to date browsers. I'm having this issue going in from mobile Facebook, not the Messenger as that's a PITA to use. Like I said it works fine in regular messenger here, buttons show up....everything hsows up.

Switch to mobile FB? Nothing shows up, just the standard FB conversation on mobile, with the text entry and send buttons, it only displays the text and nothing else....however if it was to send me an attachment I know for a fact attachments work on mobile FB.

I've tried five browsers and had to exact same issue acros now four different hardware configurations. I've removed al the extensions from the browsers, I've disabled ad blockers, I've re-enabled them, I've used phones, laptops and desktops and consistently had the same issue using mobile Facebook....not the mesenger, the mobile site that is.

@Darren: Try m.facebook.com and go to your mesages icon, hit that then to go to Textspaced and play from there in mobile FB.

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 13:56:51

@Darren: m.facebook.com

@Textspaced: RIght now I'm at the part where it's giving me the 'by continuing you acept the terms' mesage. I'm on mobile FB. I have the textspaced.com link. I have the text entry field. I have the 'send' button on FB. iI have nothing else on the message. If you go back to the message I got when I died, it ended after Options: with zero buttons showing up on the mobile platform, period. It's a weird one that it doesn't seem to work on mobile FB at all for me, I've like I said tried different browsers, extensions, turned on and off ad blockers, tried different computers, phones and tablets all to no avail. THis happens whenever a button shows up. It only ever sends the text of the message.....not the buttons or menus. If I switch to the regular FB and go into messages...it works flawlesly however.

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 14:11:21

Hi JaceK,

When I try the mobile version it seems to show the buttons, they don’t look as nice but seem to be there, they don’t seem to show on the light low bandwidth version however.

If it’s an issue with Messenger I get let Facebook know, but there is not a lot more than that I can do, and playing via the method mentioned by other people here would be best.

Thumbs up

2018-10-05 14:59:14

So, in most cases the problem is the lack of buttons, if I got it right.

Well, since buttons do appear nicely for me, I can only assume its some configuration issue: Might be Facebook, Messenger, Browser, Screen reader, or even Operating system...
Perhaps even the combination of those...

There must be something, what we, who can play the game, have configured differently from those, who cannot play it.

Maybe we have made certain modifications, which others have not made yet?

Can we remember or guess, which modifications could those be?

This is the question here.

As for me, there is a sighted computer expert friend of mine, who I asked to install windows 10 for me, (back then, round a year or so ago), and make it as accessible as possible, along with all my other programs running under it.

The only 2 programs I configured myself are my NVDA screen reader, and my Google Chrome browser.

Plus, there is the example of the browser game Torn City I mentioned, where the case is right the opposite, it's me who has troubles playing it, exactly due the lack of buttons, while others claim they have no such problem, even with the same configuration, platform, and screen reader as mine.

I wonder if this post of mine can provide us with some clues?

Thumbs up

2018-10-05 15:19:06

Wel at least for me the only common thread is mobile FB which doesn't display anything button wise across the latest Firefox, FF 52, 56, Waterfox, Chrome and Chromium. I've installed, whitelisted, and uninstalled ad blockers. I've even tried on a second FB account and no luck. I've tried on tablets and phones with no luck either so I'm running out of ideas. I even disabled the screenreaders on said machines entirely to eliminate those as possiblities. Again, no luck with butons showing up....yet when somebody else sends me an attachment in FB on mobile site, it shows up fine. If I use regular FB, it works fine. I'm beginning to think it's something specific to mobile FB and Firefox, since that's what I use mostly....though given it also appears in Chrome and solely afects mobile FB I got no idea at all. It solely sends the text in the messages and I know I ain't changed anything in my FB settings to block buttons as said they show up fine on the desktop site.

I'm now majorly confused here since I've tried different hardware, browsers, and eliminated variables and still the same isue remains on mobile FB. @Textspaced try this:

Grab Ublock Origin on Firefox and install it, don't change a single thing, and try to play Textspaced on mobile FB. That may be a starting point....however as stated, I have Ublock Origin on currently, and can't get butons. I can however get everything else, atachments, images, etc on FB chats.

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 15:20:53 (edited by JaceK 2018-10-05 15:23:28)

One more:

THis is weird. I'm on the regular mobile FB (the high bandwidth one)  yet it's acting like I'm on low bandwidth as far as things not showing up? Any chance you guys could rework the game to work with the low bandwidth stuff?

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 15:32:26

Ok now, here is an important question:

Those with button problems: Do game options appear, but without buttons, or no options appear at all?

Asking this, for I experienced, and it was also confirmed by other, sighted players, how options sometimes disappear, mostly after being idle for a longer time.

In those cases, one only has to type something in, into the dialog or message box I mean, anything, then press enter, and the options will appear again, along with the buttons.
(at least for me)

Thumbs up

2018-10-05 15:42:00

Nope, typing a message in just repeats whatever was sent with zero butons or anything. See the death message on the previous page I posted. It ended after Options: with no options. Typing anything in just repeated the message with no buttons at all

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-05 21:27:09

Hi JaceK,

So are you actually on the gameover screen? If so, could you let me know what your captain name was?

Thumbs up

2018-10-06 08:20:56

Well, at 1st it does repeat whatever you typed in, but a second after it options and buttons appear...at least for me.

Btw how did you manage to die permanently?
As far I have found out, it's...errr...not such an easy task, LOL!

In normal cases you don't even die actually, but escape in a capsule, aka escape pod...

While the only way of permadeath I know of, (by now), is being idle over 14 hours in a sector with a black hole, which, accordingly, sucks you in after that time period.

But if you had received the "game over" message without that happening, then you must have found another way already, LOL!

Thumbs up

2018-10-06 08:28:11

@344: It happens after every single message here. I started a new account and got to the point about accepting the terms and conditions. On regular Facebook....the buttons appear fine.

On mobile FB.....nothing shows up after the www.textspaced.com link. It's almost as if it thinks I'm on the low bandwidth mobile FB

@345: I somehow died by not logging in after the very start when the first ship jumps in....and.....had computer problems and couldn't log in, so....died.

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-06 11:49:00

Hi JaceK,

So just to be clear, you can play on the normal version of Facebook?

Thumbs up

2018-10-06 12:34:28

Yes I can play on regular FB fine but I'm not a fan of regular FB really. I'm not sure if mobile FB's putting me in the low bandwidth mode even though I'm not on a low bandwidth connection or not

If in doubt, chocolate and coffee. Enough said.

Thumbs up

2018-10-06 17:35:18

Strange, for me it's right the opposite, mobile FB seems to work in a much more accessible way than the original one.

So I guess buttons would probably not appear for me, if I would try to use the original one for the game, LOL!

Btw it's probably a configuration related issue, but mobile FB constantly drops me into the dialogue box, by instantly activating it even.

In the case of Text Spaced, which uses many of those so called "macros", aka direct commands, it is sometimes useful...but sometimes can also be annoying.

Thumbs up

2018-10-27 07:35:29

That’s pretty strange JaceK, it’s normally  the other way around. Unfortunately there isn’t a great deal I can do at this point, as it’s Facebook that need to improve their accessibility features, that we keep reminding them off.

Caccio is able to play the game fine and even you Discord, but I’m not sure what further advice he can give.

Thumbs up