26

I uploaded the editor again.
I may have gotten a liiiittle carried away, and included the map editor, the Swamp Platformer, and the experimental 3d editor all in the same archive.
This includes the map/tiles file, which loads the most common tile set.
https://www.sendspace.com/file/eiqf2s
I didn't mention this before because it was still kinda sketchy, but you can use h to toggle the building helper, and shift+h to set the building helper's data. The problem is, I couldn't get the pathfinding to work right, so it only sets how far a tile is from the exit, without paying attention to turns. So if you want to use this, you'll have to set the complex stuff by hand. That's a lot less tedious than it sounds, but I'm not sure I'd want to try it on the more complex buildings like the Hospital or the Defender map, lol.

Some of my games
Keep up to date by following @Jeqofire on twitter!
Ear Ninja?

Thumbs up

27

No log here, jsut when i hit enter to stat it the game exit by it self

Thumbs up

28

What's in the debuglog?

Some of my games
Keep up to date by following @Jeqofire on twitter!
Ear Ninja?

Thumbs up

29

where is debug log located?

Thumbs up

30

I would be interested in fyquest as well as in other campaigns wich work with the actual swamp Version. Is there still something going on regarding single Player?

Thumbs up

31

I'm having the same problem, The game exits when i want to play the campain. Here's my debuglog:
Starting program
Loading JAWS Api
Version is 3.7
Sapi is set to 0
Loading settings/progress
Creating DirectSound...Using DX8
Setting Coop level
Sound finished.
First 'sayit'
First sound test.
Using English
Screen resolution: 1366x768
Client resolution: 11850x7905
Center point: 0,0
Load finished.
error in loadmap: Input past end of file
PatrickRPG

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

Thumbs up

32

hmm I remember checking the maps in the latest version for changes that would cause this sort of thing, and didn't find any. To be sure, are there multiple campaign files? Ex, fyquest, fyquest29, fyquest35? If so, try fyquest35?

Some of my games
Keep up to date by following @Jeqofire on twitter!
Ear Ninja?

Thumbs up

33

Oh yes 35 one worked

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

Thumbs up

34

Hello, I found some bugs in the swamp editor.
1. Edit menu is somehow broken, when I want to change the color of a platform, it will change to the first color in the list.  Idk if is it the same in change tile menu.
2. Smal bug in coordinates. I was standing in the up left corner, after pressing shift v I received 1 1 coords, but when I placed marker, I placed it on 0 0.
That is all, sorry for my english.

Thumbs up

35

Hi there. I want to mention two things. First, the both download links for the map editor are giving me an error, referring to file not found. How ever i got the one you said in another post but idk if that is the correct one. It has a jq3d executable file which seems to be the map editor but isn't it for the swomp sidescroler?
second is about the campain. I got dollar -30 today and couldn't find something to make it more. It was by an accident though i wasn't expecting it to go under 0. Thus i couldn't go anywhere with the buss and was stuck in the strip mall or what ever the map name is big_smile
thanks for reading

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

Thumbs up

36

I didn't realize there was  a way to get negative money... the only other way I can think of to get out of the stripmall is if you found the car-keys, but I don't remember if you can use the cars at the stripmall or not. hmm Thanks for bringing this to my attention.

Jq3d is its own thing which has nothing to do with Swamp. It's more of a concept demo. The Swamp Platformer's editor is still only the one built in to the game.

Re: map editor bugs. I recently noticed the color bugs, and hopefully will be able to solve it eventually. As for the coordinates, that's another 0-based vs 1-based issue I missed when trying to clean those up. Thanks for pointing it out.

Some of my games
Keep up to date by following @Jeqofire on twitter!
Ear Ninja?

Thumbs up

37

Hi, AGain  me big_smile.
Yesterday I started building a larger map and sometimes I made a backup.
When I loaded the backup 2, the graphics did not move when I moved in the game.
I tried to clone the first backup of the map where the graphics works, but the clone got the graphic problem too.
Sorry for my english.

Thumbs up

38

Since a lot of folks seem to be having download issues, if somebody can upload *only* the map editor, I'll get it hosted on my site and post a link.

Thumbs up

39

Oh there's another thing. There really should be a way to heal allys i don't know if it is possible in swamp campain scripting but my ally dead somehow and it was giving me errors that the variable y for ally.warrior or something like that could not be found every fiew second. And i was about to get the keys for docman so i somehow lost so much haha

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

Thumbs up

40

I think the chat command to fix ally bugs is /res

Some of my games
Keep up to date by following @Jeqofire on twitter!
Ear Ninja?

Thumbs up +1

41

Na that didn't work

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

Thumbs up

42

Maybe just res, without the /?

Some of my games
Keep up to date by following @Jeqofire on twitter!
Ear Ninja?

Thumbs up

43

Yup that worked. Thanks a lot

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri

Thumbs up

44

I can't grab the map editor, its erroring out on the sendspace link.

I'm a cat! What's mine is mine, and what's yours is mine to :P XD

Thumbs up