2018-02-05 02:18:49

Hi guys.
Recently, I replaced my laptop. And while everything, for most of it, is going well, I do have 1 issue, that I just cannot, for the life of me, fix. The laptop in question is using RealTech audio, with Dolby audio as enhancement. basically, if something loud comes into the speaker, my screen reader fades. Let me give an example. Say I'm on redspot, and I use an item grabber. My prefered screen reader will flat out fade into nothingness. when item grabbing is finished, speech will slowly restore to full volume. The type of screen reader doesn't matter, I reproduced this with both JAWS nd NVDA. If that wasn't bad enough, the same seems to be happening with youTube as well. If I click a link, and if I'm on, say, teamTalk, teamTalk will flat out fade out as well. To make things a nightmare, when I plug headphones into the 3.5 headphone jack, the laptop doesn't keep seperate volumes for the main speaker, and the headphones. more specifically, the thing will still say speakers. it will notify me that I plugged in something to the jack, but nothing will actually happen. With all that said, does anyone have any ideas? I'm willing to change sound drivers, but disabling dolby, which some have recommended, basically removes 80% of my volume, so that is pretty much the only thing I can't do. Using different drivers then disabling dolby may work, but my knowledge of audio is essentially nothing, so any help/suggestions will be greatly appreciated. Thanks all.

Thumbs up

2018-02-05 06:19:20

You may try looking for disable all enhancements under sound settings. Most don't have it, some do.
You could try installing drivers for a machine that isn't yours as long as it's realtek. This particular link is for a dell machine provided by @TristanB1206 on twitter
There is a link to hopefully generic realtek drivers but I don't know if it would solve your problem.
https://github.com/distantorigin/xps-enhancements
Hope this helps!

Thumbs up

2018-02-05 08:57:56 (edited by afrim 2018-02-05 09:10:33)

Do you have a dedicated application for dolby? If it happens that you have one, then we can sort out the problem by disabling the enhancements within the program. I have DTS installed on my HP laptop, and it has a dedicated DTS audio control panel application where I disable the audio enhancements, among all.
There is also another option to completely disable the Real tech Audio Manager service, but I don't recommend doing it if you don't have sighted help around to assist you if the whole audio service is disabled.

Thumbs up

2018-02-05 12:59:34

post 3, thanks for the suggestion. I sure do have the dolby audio icon, but disabling enhancements really decreases my volume level. I'm not sure if that's expected. if I disable dolby, any ways of then increasing the volume level? as for sighted, I have my half broken old laptop, I should be able to NVDA remote myself if it came to that. if it means it would fix the problem, then I'll do it. post 2: this is a Lenovo, with what I presume the lanovo provided audio drivers.

Thumbs up

2018-02-05 13:25:01

Sorry I can't offer any help, but this definitely sounds like a case of the dreaded inaccessible audio enhancement software that seems to come with every laptop nowadays. I'm guessing there's a single box you can uncheck that handles audio ducking.

Thumbs up

2018-02-05 14:37:56

I had this problem on my desktop as well. Disabling all enhancements did indeed fix it. My only concern is if I ever have to refresh this machine. Unless I restore to factory default settings, I suspect I may not have audio anymore unless Windows downloads the Realtek software again.

Thumbs up

2018-02-06 13:48:12

If it's windows 10, even if you opt to keep nothing and do a fresh install, even from a windows image, you shouldn't have to worry about that, mostly.

Thumbs up

2018-02-06 14:22:40

if I disable enhancements, any ways to then increase the over all volume?

Thumbs up

2018-02-06 16:37:41

Try going into sound settings, into properties of your default playback device, and under the advanced tab uncheck exclusive mode.

Thumbs up

2018-02-06 21:27:31

Hello everyone. Here is a youtube vid I produced a few months about this Dell gaming laptop I have and I documented the issues I was having with the audio driver. I'm using the built in windows 10 drivers for now. I wonder if unchecking the exclusive mode thing would also fix my issues? The vid explains all the issues I was having.   https://www.youtube.com/watch?v=rriGKjJfWxY

Thumbs up

2018-02-06 21:53:21

not sure about windows 10 but in windows 7, try going to audio in control panel, select your sound card then in properties go to advanced. tab to exclusive mode and uncheck it. stops programs turning everything else down when they are in control.

if duct tape doesn't fix it, you haven't used enough.

Thumbs up

2018-02-10 14:30:02

hello fokes  plese help me for  refixing  hd audio manager  problem.  recently i installed win 10   on  asambled  computer  bt  i lost my inhansment tab  replaced with special sound  tab

Thumbs up

2018-02-11 16:39:52

post 10, how do I get the generic windows 10 drivers? in the meantime, I disabled volume leveler, (not sure of exact wording) but left dolby enabled. while that didn't fix things being louder than others, it did fix the ability for  dolby to mute my screen reader.

Thumbs up

2018-02-11 22:18:18 (edited by austingrace 2018-02-11 22:27:06)

I honestly hate how these manufacturers are messing up the sound drivers. It really drives me crazy. Everything is autogaining and whatnot. If you looked at that linked video above you will hear just how much it messes with eloquence and the intro to grizly gulch. It makes things that are mono into stereo.. Plus they have these inaccessible interfaces that even screen review in NVDA are not able to interact with. If you listen to the end of my video you will hear an example of that. In terms of getting the windows driver to work I had to go into the properties of my sound card in device manager  and choose the driver manually. Just hit update driver and  then let me pick from a list of drivers on my computer and just hit high definition audio device or whatever. This is the text of the dialog where it is. Browse for drivers on your computer
Search for drivers in this location:
C:\Users\YourName\Documents
Browse...
Include subfolders

Let me pick from a list of available drivers on my computer
This list will show available drivers compatible with the device, and all drivers in the same
category as the device.

Next Cancel  I'm really terrible at explaining things so I hope that helps. smile  I do audio production for a living and I need clear signals going to my headphones and these new realtech  drivers do not give the clean signal i need. There is way too much processing going on.  Yes I do have a mixer but sometimes it is not feasible  for me to carry the mixer and I need to edit audio on the onboard sound card of the laptop.

Thumbs up

2018-02-12 00:21:33

guess I'm really screwed, because following your directions above, gave me a message along the lines of windows has determined that the best drivers for your device have already been installed. I guess mine is even worse than yours, because in your case, you could choose, but in this case, I can't. any other ideas are welcomed, however.

Thumbs up

2018-02-12 18:37:15

The procedures explained in post 14 worked fine for me on my HP laptop.

Thumbs up

2018-02-12 18:38:19

Hello. I'm going to produce a youtube video demonstrating how to do this. smile I'm much better at audio recording things instead of writing them down.  I'm sorry the driver thing did not work. sad It makes me want to buy older or custom built computers from now on.

Thumbs up

2018-02-13 14:41:57

hi, try turning off dolbi and see if, loudness equulisation is availible under the enhancements check boxes. if so, it may solve your issue.

There's a place for me in this universe. and our journey continues on, together

Thumbs up

2018-02-14 05:16:13

Well I'm glad I'm not the only one that has been having issues with these realtech drivers.  LOL

Thumbs up

2018-02-14 14:08:32

Oh god, dell has this thing called waves maxx audio pro. The guy I linked to has a dell which is why he created the repository. Well, this is one of the reasons.
Pretty much once a laptop has audio enhancements, there is almost always little or nothing you can do to disable them. I got lucky in that my acer has a disable all checkbox, which actually disables the very minimal enhancements that were active out of the box.
Post 13, you uninstall the driver for the audio device including the driver software, from device manager. I really don't recommend the default audio drivers though, as they aren't all that great. That, and you almost always lose the ability to use headset microphones.

Thumbs up

2018-02-14 19:15:45

Oh yeah, I have max Audio too but compared to some others it does have some accessibility and you can at least change presets and such things.

Thumbs up

2018-02-14 21:39:45 (edited by austingrace 2018-02-14 21:40:37)

Hello. I have nothing but trouble with max audio pro. I lost the use of my sub woofer on my laptop because the built in drivers don't support it.  I'm actually going to give that dell driver a shot ou linked to.

Thumbs up

2018-02-14 22:12:07

Hello. Do you know what exactly are the keyboard clicks to disable secure boot on a dell laptop? I was able to locate the boot tab using seeing AI on my iPhone but did not want to go any further.

Thumbs up

2018-02-15 07:33:12

hi another thing that came to mind is this. when the sound control pannel opens. continue pass the sounds tab. past the play back tab. until u here comunications tab. in there push the radio butten, using down arrow. until it says, nothing, radio butten checked. then hit okay. this will stop windows from messing around with muting audio or lowering volume for apps as well. in conjunction with the enhancements this comunications tab is set to reduce audio by fifty percent. if left to its own  default state. when it thinks in coming calls are coming in and more. when u set it to the, do nothing, radio butten, u saying to it, don't fluff around with my audio. leave it alone. i'll manage it my self

There's a place for me in this universe. and our journey continues on, together

Thumbs up

2018-02-15 11:29:44

regarding post 24, that's a nice idea indeed. unfortunately, that was already checked, because of skype. regarding post 17, when I disable dolby, the enhancements tab has one check box, which is labled  as disable all enhancements. as for post 16, think it was, the process outlined by post 14 would work here as well, but windows claims I have the latest and greatest drivers enabled, and I have not had luck finding the generic Microsoft drivers as of yet, so I could replace realTech with them.

Thumbs up