2018-02-06 00:19:49

Hi all,

So, I've got LocaleEmulator, I've got JGT, everything appears to be fine.

After running Alternative Magic though, NVDA just says "magic", which is okay I guess, but both return keys aren't working. At all.

How do we go about fixing this problem? I remember having this issue before but I remember having to hit enter multiple times. I hit enter a bunch of times and no matter what nothing happens.

I'd appreciate any help on this.

Orin

Thumbs up

2018-02-06 05:39:09 (edited by Ian Reed 2018-02-06 05:45:02)

Check out the heading: A few notes to help you enjoy Morokuma's text games, in the JGT manual for some good tips about playing those text games.
Here are a couple that might be related to your issue:
• Enable both the auto translate last spoken and the auto translate clipboard features. The first is needed to auto read menus, the second is needed to auto read story and NPC dialog.
• Remember to change the keyboard to Japanese by pressing alt + shift once the game is open.
• In the newer text games, you need to hold a modifier key when pressing enter, escape, or tab. I usually hold shift, but control also works. The older text games don't have this problem. A better solution is to install Tyler Spivey's Japanese game fix addon to fix this. You must also rename the game's executable to be play.exe if using that addon.
• When alt tabbing away from the game and back, NVDA has a hard time getting focus on a control again. In the newer text games, press control + Home to regain focus. In the older games, when on an NPC dialog you can just press enter. If you were in a menu you'll need to route the mouse to the current control and click it. I use object navigation to navigate to the list view. I do this with NVDA + numPad2. Then I press NVDA + numPad/ to route the mouse there, and then just numPad/ to click the mouse button.

Hope one of those helps. I just tested and Alternative Magic is working for me.

Edit: One other thing I noticed in Alternative Magic is that I have to hold the enter key for half a second to get the game to pick it up, rather than tapping it quickly as I do normally.

A couple other helpful tips:
• If you didn't quite hear the last speech, press NVDA + C to have the clipboard read it to you again. Or alt tab to a text editor and paste it there for easier review.
• The text is not automatically read in status screens. Highlight one or many lines of text and then press control + C to have it automatically translated. There is a limit on how much text can be translated at once, so highlighting everything at once won't always work.

~ Ian Reed
Visit BlindGamers.com to rate blind accessible games and see how others have rated them.
Try my free JGT addon, the easy way to play Japanese games in English.
Or try the free games I've created.

2018-02-06 06:49:46

if I use the japanese keyboard, will the enter key issue will be fix? , same here, have a to hold enter a bit big_smile

Thumbs up

2018-02-06 07:06:33

Where is Tyler's Japanese game add-on?

Orin

Thumbs up

2018-02-06 09:56:35

Also, you need to change the key response to minimum, which can be located as キーレスポンス= value in the settings file. By doing this, you can tap the enter key to procede the dialog. Of course, the NVDA issue will persist, so you still need Tyler's addon.

I really tend to miss direct messages. If you want to contact me privately, please send an email instead of a direct message.

2018-02-06 10:45:51 (edited by JasonBlaze 2018-02-06 10:59:51)

@Orin(4): the link to the addon is on jgt user guide, but I got 404 not found, so here's a new link
https://www.dropbox.com/s/ngtg2u54hckam … addon?dl=1

Thumbs up

2018-02-06 10:59:11 (edited by JasonBlaze 2018-02-06 11:01:40)

sorry for double posting but, @nyanchan:
here's my volue:
;エンターキーを押した際の反応速度1~5000100は0.1秒
; 安定値 10~100
keyレスポンス=100
do you mind to change the volue?
oops the first one isn't 5000100 lol, 5000 something 100

Thumbs up

2018-02-06 18:54:36

I've updated the link to the addon in the JGT manual.
@JasonBlaze, thanks for pointing out that it was broken.

~ Ian Reed
Visit BlindGamers.com to rate blind accessible games and see how others have rated them.
Try my free JGT addon, the easy way to play Japanese games in English.
Or try the free games I've created.

2018-02-07 02:49:44

@Jason
=1 is just fine. I don't even know why the option exists and the default is 100.

I really tend to miss direct messages. If you want to contact me privately, please send an email instead of a direct message.

2018-02-07 12:14:12 (edited by Orin 2018-02-07 13:06:44)

I set my key response to 1, and notice that when I don't run it using LocaleEmulator, JGT can't translate it because it's running in English, but the key response is honored and I can press enter just fine.
When I run it with LocaleEmulator, with Tyler's addon installed, I have to hold or press enter a number of times and the key response doesn't seem to make a difference sad

Edit: Okay, so to make it easier for me and those of us on virtual machines for people that don't have an NVDA key, I was able to change the auto-translate clipboard key easily enough.
"kb:shift+control+h": "toggleAutoClipboard",
       

However, I tried to change the translate last spoken key...

        "kb:shift+control+y": "translateLastSpoken",

Hmm, I notice the indentation isn't there like the previous one. Could that be why it's not working? In any case, no matter the key I set, whether it be C, L, T, even removing shift, it refuses to set. Auto Clipboard works fine though.

Edit 2: Despite changing that line in the file for auto translate last spoken, the default key still works and my changed one does not.

Orin

Thumbs up

2018-02-10 19:48:17

@Orin, I have no idea on why the game would not honor the key response when you run it with locale emulator.
I just tried rebinding the translateLastSpoken key and it worked for me.
All the key bindings have exactly 2 tabs of indentation on my copy.
You have to restart NVDA to get changes to that __init__.py file to take effect.

@nyanchan, when I search for the key response text you show in post 5, in gameÝ’è.ini my text editor does not find it.
Do you know if that file is supposed to be opened with UTF8 or a Japanese specific text encoding?
Would you mind posting an updated file with the key response set to 1?
Then I could add it to the JGT manual for other people who have trouble.

~ Ian Reed
Visit BlindGamers.com to rate blind accessible games and see how others have rated them.
Try my free JGT addon, the easy way to play Japanese games in English.
Or try the free games I've created.

2018-02-11 13:16:53 (edited by nyanchan 2018-02-11 13:17:42)

Sorry Ian, the correct one which matches the search is keyレスポンス . I thought the file was ANSI.

I really tend to miss direct messages. If you want to contact me privately, please send an email instead of a direct message.