2017-11-21 14:25:07

I need to edit a small file of binary data. Is there such thing as an accessible hex editor? It doesn't need to be big or fancy or have a lot of features, just something basic will do.


Thumbs up

2017-11-21 19:26:50

Try HXDEdit or whatever that's called.

"On two occasions I have been asked [by members of Parliament!]: 'Pray, Mr. Babbage, if you put into the machine wrong figures, will the right answers come out ?' I am not able rightly to apprehend the kind of confusion of ideas that could provoke such a question."    — Charles Babbage.

Thumbs up

2017-11-23 15:03:36

Thanks! That worked great! Once I figured out how the program works with a screen reader it took less than a minute to do the edits I wanted.

Thumbs up

2017-12-03 18:04:59 (edited by x0 2017-12-03 18:05:26)

how does it work with a screen reader. If there's an accessible hex editor then I need this!
Edit: using NVDA only here.

An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.

2017-12-03 18:54:38 (edited by Orko 2017-12-03 18:55:35)

It worked well for me. The one thing I had to get used to, though as I think about it, it makes sense, is that each byte seems to appear twice, but it's simply because the screen reader reads the whole byte rather than the individual numbers.

So for 0x15 the first time you hear 15 you are on the one, the second time you hear it you are on the five.

I'd recommend making a small text file to experiment with to help you get used to how the screen reader presents the hex editor to you before you start working on a real file.

Oh, and by the way, I use JAWS.

Thumbs up

2017-12-03 20:38:47 (edited by x0 2017-12-03 20:48:44)

I get that when I hit ctrl right and ctrl left, which navigates by nibble. If I use the arrows I hear one digit. I guess this is the first digit of the next byte?
Apparently after you get past your hex data you get the bytes in the specified charset, so I set my bytes per row to 4 so I could read it. I just wish the offsets didn't come with all the fuckin 0s. Up and down arrow navigates by row, and the first thing NVDA reports is the offset, then your bytes. So I set my offset base to decimal so I could tell the difference.

An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.

2017-12-03 21:12:55

Yeah, I used control so I was navigating by nibble. At the time I was looking to do a quick and dirty edit so I didn't spend a lot of time tinkering with the settings or playing with a junk file to figure everything out about it.

Thumbs up