1

Have any of you encountered this before, by any chance? If nothing is played through speakers for 5 seconds, the next time a sound is played there is a delay. This, as you can imagine, is the most annoying thing ever with a screen reader. I'm told that visually, the display doesn't dim, and it seems like keystrokes go through just fine, there's just a one second delay before I get audio feedback through my screen reader about anything that happened. This is what makes me think it's specifically an audio problem rather than the computer going into some kind of power saver mode.
It's not that the first second of audio is cut out either, the full message plays, just after a delay.
Nothing I could find anywhere in settings seems to have anything to do with this, and technical support had no clue what I was talking about so I figured I'd ask here in case any of you have had to deal with it.
It's a new Dell XPS 13, with an 8th gen I7 and 16 Gigs of RAM, so I refuse to believe it's just the computer being slow.
Any help would be greatly appreciated.

Thumbs up

2

Hello.


I'd recommend updating all the drivers if they're not updated already.


You could try resetting windows and installing everything again, this might work.
Apart from that, I don't really know what to suggest. If you can, a refund might be a good idea. Next time you buy a laptop, i'd recommend going to a store and testing it out with narrator before buying.

If you like harry potter fan fiction, click on this link to download a zipped folder containing 9 point something gigs of harry potter fan fiction when unzipped. It's around 3 gigs zipped. https://tinyurl.com/y9dl9zev

Thumbs up

3

It's not annoying enough to justify a refund.
It seems to be a feature rather than a bug, as uninstalling and reinstalling drivers didn't help.
I only asked in case there was an easy fix, if not I'll live with it honestly.

Thumbs up

4

Try going into Control Panel->Sounds and turning off Audio Enhancements.

Thumbs up

5

First thing I did. Unfortunately no dice.

Thumbs up

6

Ugh, another victim of bullshit tactics by laptop manufacturers to fuck with shit they have no god damn idea about. Try that Silenzio program, it will keep the sound channels open by playing or sending basically nothing to the sound card all the time. I have to do this to my laptop. I don't have a link though, so if someone can't post one, I'll upload it to dropbox and post it then. Silenzio will set itself up to run when the computer starts up, and will just continue to work, it also has the ability to redirect its output to another sound device on your system, though external devices *usually* with the exception of bluetooth ones, do not experience this

The bipeds think this place belongs to them, how cute.

Thumbs up

7

The only thing I get when google searching this is a white noise player. Is this what you mean?

Thumbs up

8

realTech is at it again. this, in short, is a realTech feature. not a bug. my only question is, what brand is your PC?

Thumbs up

9

Dell XPS 13-9370.
And yes, I figured it was some kind of feature to save power. Digging through the included audio management program didn't help though, it doesn't help that the thing sucks in terms of accessibility.

Thumbs up

10

I have the same issue with my Surfacebook 2.  I'm always listening to music so it's not really a problem.  You might be able to find a solution within your advanced power plan settings.  I honestly have no idea though.

Mammon slept. And the beast reborn spread over the earth and its numbers grew legion. And they proclaimed the times and sacrificed crops unto the fire, with the cunning of foxes. And they built a new world in their own image as promised by the sacred words, and spoke of the beast with their children. Mammon awoke, and lo! it was naught but a follower.
from The Book of Mozilla, 11:9

Thumbs up

11 (edited by Munawar 2018-06-03 18:36:44)

You can install Windows Generic drivers. The guide is here: https://neosmart.net/wiki/fix-realtek-audio-delay-lag/

They even mention your model as exhibiting the problem.

Thumbs up +1

12

@Munawar Problem mostly solved! Thank you so much! Now at least the audio doesn't take a full second to come back. It tends to cut out the first half word spoken by a screen reader if nothing is played for 5 seconds, but compared to the previous problem this is not nearly as annoying. I probably only notice it because my speech rate is set so high.
@Ironcross32 If you do get a chance, I'd really appreciate it if you could post that program, in case this problem ever does come up again. seems like a useful thing to have. Plus it might fix this last lingering issue.

Thumbs up

13

You're welcome smile For the audio-fading problem, here is where you go into Sounds and turn off audio enhancements. You might have to do this from the applet of your sound card instead of Windows Control Panel. Your sound card is auto-levelating your sound to keep it equalized, and it can easily be switched off.

Thumbs up

14

going through sound settings and disabling audio enhancements changes nothing, unfortunately. Like I said though, this is significantly more tolerable compared to before.

Thumbs up

15

I was expecting it to be a dell. there has been a similar issue on the win10 mailing list. this is realTech combined with dell audio, who's accessibility, as you've also pointed out, sucks. I'm glad you got something that works, though.

Thumbs up

16

Hi rashad, RealTek uses their own application to enable sound enhancements and from what I recall, disabling it through sound settings won't help. You need to open the RealTek application itself. I don't remember how to get there, but try some searches in Control Panel for realtek and audio.

I've gotten the RealTek app to work using Narrator in Scan Mode. Using it, I was able to click on the cursed checkbox to switch off enhancements, and all my sound fading went away. big_smile Yes, it's really not accessible (even NVDA failed miserably in object navigation to get at the controls I wanted.)

My new laptop doesn't have a RealTek card though so it's just using the standard Microsoft Generic drivers. So, I can actually use the sound card for what it's made for now: playing sound. Simple.

Thumbs up +1

17

What if you just disable the manager in startup settings? Would it default to normal drivers or would you have no sound?

Thumbs up

18

would have no sound. you could revert to the standard drivers, made by microsoft, but dells don't seem to appreciate you doing that to them.

Thumbs up

19

@braille0109, they do let you do it. I did it on this Del and it worked fine.

Thumbs up

20

they let you do it, but I've had countless complaints from people regarding their headphones not properly switching, sound quality decreasing, headphones not working at all... while I did this to a bunch of computers, due to feedback and other people's experiences, I'm scared to recommend it with a handful of brands. asus and dell don't seem to like the idea, that's what I know of so far, anyway.

Thumbs up

21

some soundcards if you try to do that will reinstall their own drivers, hp is notorious for this but dell can do it too. You pretty much have to have OCR or sighted assistance. OCR might not even work, because of their tabs. I've used object nav to fight with it sometimes and gotten some resuls, but this was on school win7 computers that were using autoleveling, which makes playing audiogames impossible, and had this weird room echo bullshit over my speech. I would select the voice preset and most of it would go away, sometimes there's a custom button that just defaults to flat everything.

----------
An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.

Thumbs up

22

Computers really shouldn't be allowed to ship with such inaccessible software preinstalled, Microsoft could probably put their foot down on that if they cared enough...
I'm not asking for something amazing, but holy shit, come on, we're not even talking about benchmark graphs or GPU adjustment or color calibration here...

This... -- Is CNN'.
Well Ted, it sure looks like there's been uh, quite a bit of violence around here
"aaoh, that violence was terrible'!"
Yeah it was, pretty bad.

Thumbs up

23 (edited by flackers 2018-06-05 00:57:58)

And they're screwing with the area that's most important to screen reader users, so they're rendering laptops almost unusable for us by default. And these kinds of audio enhancements became the norm as long ago as 10 years or so, and so by now they must be well aware of the trouble it causes people like us. I wouldn't mind so much if it actually made laptop speakers sound any better, but it doesn't. It's utterly useless bloat as far as I can tell.

Thumbs up +1

24

maybe autoleveling could be good on laptop speakers, but they fuck over headphones. I pretty much had to switch to using external sound output for everything, especially in the PE, where my soundcard isn't even supported! There is hope though. The main reason most of that's inaccessible is the graphic equlizer, but yeah there are other things. But I got a Lenovo ideapad320, though the other pads should work, I've heard the thinkpad420 was good, and it came with dolby and I'm like, oh boy here we go again. Found the conrol panel... It's completely usable! Not just object nav, it has a tab order, the graphic eq is combo boxes and it just... Works. I disabled the autoleveling in a heartbeat. And if I truely wanted to use the eq I could. That, is a good control panel.

----------
An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.

Thumbs up

25

speaking of ideaPad 320s, the first thing I did to mine was getting rid of dolby and realTech. now trying to fix the lag, that most ideaPad 320s suffer of, would be interesting to hear your experience with yours privately.

Thumbs up