1

Hi folks,
does anyone know an accessible program to remap keys on the keyboard that works reliably on Windows 10? I'm using bootcamped Windows on a macBook Pro with Apple's Magic Keyboard. At the bare minimum, I at least need to switch the left Windows and alt keys around. That the keyboard treats the key in the normal position of left alt as the command/Windows key is really starting to annoy me.

Ages ago, I used to use Keytweak, but despite the fact that it seems to be abandoned nowadays, it doesn't seem to work for me with NVDA on Windows 10 Pro Fall Creators Update any more. Either that, or I was no longer able to figure the right way to remap a key when coming back to it after several years.

I've tried Sharp Keys and another one whose name I can't remember any more, but with the same results.

I'm even willing to do that manually in the registry, if anyone could give some pointers.

Thanks,
Lukas

Thumbs up

2

I used Sharp keys on one occasion and it worked fine.
You are willing to learn how to remap keys by manually going to the registry editor, while in fact it's far easier to learn how to use a program that automatically does what you need.
Sharp keys is accessible with NVDA and I myself do not find it difficult to use.

Thumbs up

3

hi, what, exactly, is the issue with sharp keys? maybe we can help you with it.

Thumbs up

4

All right, so I decided to give Sharp Keys another go based on your recommendations. The main program screen is accessible for the most part, except for one control that NVDA just reads as pannel, but the trouble starts when I click the add button. There are two controls, apparently the lists of keys to choose from, that NVDA just reads as unknown even when arrowing through them, no matter what. And when I click either of the two Type key buttons with different accelerator keys associated, I get no accessible feedback at all.

I downloaded the thing from Codeplex which seems to be its official and most recent code repository. The version number is 3.5.

I've had this weird issue with NVDA recently, though, where it reads stuff as unknown or pannel that previously used to work fine. This started as soon as I started using this Windows 10 Pro Fall Creators Update in Bootcamp on my macBook Pro. Except for Sharp Keys, I get this in various installers all the time, and as I said, these used to work fine as far as I can remember. I was using the NVDA development snapshots from the next branch, but even after I decided to uninstall NVDA completely and then reinstalled only the latest official build, i.e. version 2017.4, with no more development snapshots, the problem still persists.

So, does anyone have any idea as to what I could do, either about the underlying NVDA issue or about Sharp Keys itself?

Thanks,
Lukas

Thumbs up

5

this will sound like a lazy reply, and certainly, a response, that suggests that I don't want to help, but that's not what I'm trying to get to. something tells me that your NVDA could be your issue, rather than anything. would it be possible, as an experiment, to use a demo version of JAWS, and see if that reads it?

Thumbs up

6

Yeah, I know. I just didn't want to be bothered by trying a different screen reader as I have a regular job now, often with 8-hour shifts, and installing the demo of Jaws takes a while. But yeah, I know I have to do something about the underyling NVDA issue eventually anyway. So I'll try that and report back. :-)
Lukas

Thumbs up

7

All right, Jaws reads nothing at all, using both the PC and Jaws cursors. Switching between the two and moving with either of them is about everything I know how to do with Jaws. :-D NVDA actually reads a lot more than Jaws at the moment. Again, the thing I installed was Sharp Keys 3.5 from Codeplex.
NVDA's OCR doesn't help much either. It does read some of the keys in the list but not all of them at a time, so choosing the one I want seems impossible to me right now.
I'm gradually running out of ideas.
How do I use OCR with Jaws? It seems to have Omnipage built in, at least that's what one of the dialogues shown during the installation suggests, but how do I invoke and control it?
Lukas

Thumbs up

8

Hi,
I am using bootcamp on my mbp as well, and sharpkeys was what I used to change the stupid key layout.
Mind you,make sure the keyboard is set to apple US keyboard,else it wont work at all and will throw up errors...

Your issue is rather strange. I can confirm that Nvda reads the keylist as unknown,however jaws here read it just fine when I set my keys up..
Grryf

Of all sad words of tongue or pen, the saddest are these, ‘It might have been.
Follow me on twitter

Thumbs up

9

Are you on windows insider? I heard recently some insider build came out that broke listviews and context menus and treeviews. I've never seen this issue before, but you can always try getting win10 app essentials from the NVDA addons page, Joseph Lee fixes all the broken insider things so you don't have to. That might be your issue, I think that addon did get an update recently that fixes the list and such problems.

----------
An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.

Thumbs up

10

Hi,

thanks for the tips, but unfortunately no, I'm not on the Insider builds. I've had this since September, i.e. as soon as I installed bootcamped Windows 10 on this machine. I've tried both the official build of NVDA as well as the development snapshots, both with the same results. I've now returned back to the snapshots, since I like their update frequency better and I figured I may as well stick to them when both builds acted exactly the same.

My system is installing updates regularly as expected, and I've been using Windows 10 App Essentials since the very beginning as well, configured to use the development update channel. Just to make sure, I tried it right now, upon reading the last post in this thread, with the latest available update, but still with exactly the same result.

I'm absolutely running out of any plausible or inplausible ideas whatsoever. At this point, I'm not even frustrated any more, just resigned. I'm officially giving up and putting up with getting used to the stupid and awkward placement of the alt and Windows keys.

Lukas

Thumbs up