76 (edited by jack 2017-06-13 00:19:42)

There we go, figured it out. Game runs without a hitch now. I wonder, is this software considered abandonware since it's unsupported, or is it still copyright just under a different name, in terms of buying/obtaining a full version of this program is concerned since it's no longer being sold. I have to say it's probably one of the most unintrusive drm systems considering it stays protective but doesn't touch the game's actual code, giving the dev more time to focus on the game and leave it to the program to worry about protection, just as long as you take the time to set the encryption template name to something that you can rest assured it will take hours to guess at, since that's what the registration is generated off of. Password managers can come in real handy here leaving you free to play around with what sounds impossible to remember, because that's what's gonna take even password guessers hours to guess. Also different encryption templates for different programs. You'd obviously never want to use the same template for all your programs. If the board allows for moving individual posts, we could move them over to an individual Armadillo topic.

I'm the only adventure at c: master hahahaha I have unlocked just about everything!

Thumbs up

77

Armadillo uses several public key encryption methods depending on the type and level of key you choose to use. Stronger systems resulted in longer keys.

But in all kases the encryption template is the one part that only the developer should ever know. It is the private key part of the public key encryption.

Since it can be up to 255 characters in length and can have letters, numbers, and punctuation marks in it, I always used either something randomly generated or some phrase from some fiction I had read. Encryption keys weren't passwords so you never had to memorize them, they are stored in your project's arm file and never in the protected program file so there's no way a cracker can simply find it, yet you'll always have access to it for making registration keys.

For checking registration keys, besides Armadillo's own internal public key verification, the farthest I ever went with it was that you had to be online for the initial activation so the registration key you entered could be verified against a database of keys I actually generated as a defense against key generators, after that your registration was never again checked online. It was my feeling that as long as the key never changed that there was no need to keep checking it.

This was for my own programs, not for Armadillo itself.

I can only guess that Code Factory's justification for the periodic checks is so that they can revoke a license if they discover that it was purchased using stolen credit card information.

What we did for Armadillo was to issue a temparay 30 day key at the time of the order so the customer could begin protecting and distributing his programs. After a short while, usually one week, if the purchase of Armadillo continued to look legitimate, we would then issue a permanent key that never expired.

If, after that it did turn out that the purchase was fraudulent, we'd enter the permanent key into the stolen key database and all future releases of Armadillo would reject that key.

By the way, the Armadillo trial period never expires, so feel free to tinker with it as much as you like. You will never see a trial expired message when you run Armadillo.

Also, when you are done with it and have uninstalled it. Everything that the installer copied to your system went into Armadillo's program folder.

There will be some registry entries left behind, but they were only data that the Armadillo program use and can safely be ignored.

Thumbs up

78

I do have one question. What exactly are nanomites? I understand that a custom build is where you/Digital River/whoever would create a build where various things were stored at random locations, so my wonderful company's build would be unlike any other, and would have to be specifically cracked. But what are Nanomites?

Thumbs up

79

I assume the reason for Code Factory continuously verifying licenses over the net is to defeat the activate, image, deactivate, restore from image trick. In this scenario, Eloquence phones home to Code Factory saying it has thus and such license. Code Factory looks at its own records and says, "Wait a minute! You told me earlier that you wanted to deactivate and I thought that was done, so this license is no longer valid, so delete it!"

Thumbs up

80

I did kind of wonder exactly what the custom builds and nanomites were all about.
I remember that if you wanted a custom build, you were taken to a web page where you could pick from number 1, 2 or 3.
So I couldn't really understand what made the custom builds "custom" as presumably anybody who visited the site at that moment in time would be given the same 3 choices?

Proud to be the official hosting provider for http://www.vgstorm.com!

Thumbs up

81

@jaybird

I don't know what's going on there, I do know that I was able to recover a lost activation using the image restore method. It's possible that Themedia discovered that exploit and has now fixed it so it won't work anymore. All the more reason to get rid of it. I paid almost $80 for it and won't be happy if I find that I can no longer use a product I paid for because of
its DRM.

Nanomites are calls to a software interrupt that are placed in area of your program that you've marked as safe for them. The code the software interrupt call replaces is moved to a table stored within the protection engine. While running, when one of these software interrupts is encountered Armadillo will intercept the call to check if it is a nanomite or not. If it's not a nanomite, control passes to the operating system to process the interrupt normally. If it is a nanomite, the protection engine looks up the code it replaced and runs it, control is then returned to your program after the nanomite call.

The point of all this is if a cracker succeeds in stripping the Armadillo protection from your program, they lose the code that used to be where the nanomites are now, and without Armadillo's protection engine intact and in place, nanomites will cause the program to crash in a rather spectacular way, usually requiring a reboot because the operating system is now compromised.

Since nanomites add extra code to your program, the instructions passed out with the custom builds cautioned you not to place nanomites in code that is either timing sensitive or get executed a lot.

Custom builds are just that, a custom build of Armadillo that only a few customers will have. Armadillo is written so that the internal structure or sequence of functions and data in its code base can be randomly reordered. That way any cracking tools that expect certain functions in Armadillo's code to be in a specific place is going to find that nothing is where it thought it would be.

For each version we'd build about 250 to 300 custom builds with each one using a different random seed to reorganize the order of functions and data in the source code. When a customer logged in to get a custom build he would be given the choice of one of three randomly chosen builds. The system was designed such that for each version a particular customer would always be offered the same three custom builds. But come the release of the next version, the build numbers he'd be offered would be changed. this was done by using their customer number and the current version number as seeds for the random number generator that would select their three builds.

Thumbs up

82

Still getting nothing from CF. I mustn't be using the secret handshake smile. So it's avangate, and failing that, an old-fashioned letter. On the subject of Talking PE, I got around to trying it today. Tested it on my laptop, and all went swimmingly, but for some reason on my desktop it worked, but I had no sound, even though both systems appear to have sigmatel's high definition audio device. Other than try installing a different soundcard, I'm not sure what I can do. And my desktop is the main PC. Have one more PC to test after this, my Lenovo music PC.

Thumbs up

83

Usb audio usually works.

I'm the only adventure at c: master hahahaha I have unlocked just about everything!

Thumbs up

84 (edited by Orko 2017-06-13 23:40:33)

I would guess that most older audio hardware works too. The NVDA installed in the Windows PE works fine on my nine year old Dell laptop.

Thumbs up

85 (edited by flackers 2017-06-14 01:50:28)

It worked on my Lenovo music laptop after a bit of tinkering with the boot menu in bios. Turned out boot lock was the issue.
The only difference I can see between my desktop and the others is that the desktop has three devices listed in the sound options and the other two only have one. It has an HDMI first then for some reason 2 high definition audio devices, one is the default, and the other is disabled. I've tried simply uninstalling the drivers for these two other devices that are disabled, but windows reinstalls them again on restart. I'll have to borrow a set of peepers tomorrow to find out which one PE is trying to use as default, and see what to do from there. I'll try a USB audio interface, but it did say in the readme that USB audio was not supported at this time. Maybe that changed and the readme didn't reflect it.
The other difference was that the two laptops loaded PE in under a minute, but the desktop took a ridiculous 8 minutes. Can't imagine why this is.

Thumbs up

86

Could be the speed of the cd drive or usb controller, depending on what you're using for the p e, disk or usb flash drive. And yes, that definitely did change. For plug-n-play devices, anyway.

I'm the only adventure at c: master hahahaha I have unlocked just about everything!

Thumbs up

87 (edited by Orko 2017-06-14 14:18:52)

My brother had a similar problem with two sound devices where he only wanted one to be used because he had no way to use the other.

I told him to disable rather than uninstall the drivers because Windows will just keep reinstalling the removed drivers.

He said that doing that solved his problem.

His problem was different from yours, but disabling the other two sound drivers might solve your problem as well.

Thumbs up

88 (edited by flackers 2017-06-14 23:31:29)

I just spent ten minutes filling out a contact form on avangate with all the information of my attempts to contact code factory, including all the dates, addresses used, ticket number, order number etc, only to find a fucking inaccessible captcha at the bottom before the submit button. Don't think anything pisses me off more than this. You can't even tell them their contact form is inaccessible because of inaccessibility.

Thumbs up

89

I don't even know why Code Factory is even using that damn processing company anyway 1What else can I say. Get webvisum or Captcha be Gone.

I'm the only adventure at c: master hahahaha I have unlocked just about everything!

Thumbs up

90

So the latest in what is turning out to be a saga of Icelandic proportion... I finally got a reply to my ticket from two weeks ago saying I should now have no problem activating. I try activating and am now getting the message There was a problem activating your license. Make sure you have a working internet connection. Getting mighty sick of code factory's shambolic software and customer service. God I wish the paypal checkout had worked properly when I purchased on their website.
I won't be waiting another two weeks for another useless response. I'll be pushing for a refund via Avangate, and researching my rights re purchases outside the UK but inside the EU. If I presented all this evidence of lousy service to paypal, I have no doubt they'd find in my favour.

Thumbs up

91

Never doing business with Code Factory again. I got my replacement key, but they won't answer me regarding why the DRM server is so slow that the program takes an entire minute to initialize.

Proud to be the official hosting provider for http://www.vgstorm.com!

Thumbs up

92

On the upside, I got to the bottom of my sound issue with Talking PE. The sound was working fine, it turned out for some reason NVDA needed to be restarted before it would speak. Why it's doing that on this PC and neither of the others is a bit of a mystery. Got a hunch it's the eloquence add on. Would be interested to see if having the eSpeak synth as the default would change matters. Not a clue how to make permanent changes to the PE set up though, and having to restart NVDA on the rare occasion i'll need PE isn't the end of the world.
That's the funny thing about all this, if I hadn't have had such a lousy time with CF, I doubt I'd ever have heard of the talking PE, and that's worth way more than SAPI eloquence.

Thumbs up

93

We've now gone from a saga to a farce. Got a same day answer to my reply saying I still couldn't activate. Guess what it read? Try entering the key without dashes and it should be fine. I wonder if I'm being trolled by code factory's tech support. I tried it thinking if this works I'll eat my own balls. It didn't. My last reply ended with who do I talk to about getting a refund.

Thumbs up

94 (edited by Orko 2017-06-15 20:06:14)

Things may have changed in the years since I last had to get a refund through PayPal. Back then if the vendor can show that what you paid for was in fact delivered, you could not get a refund. If that is true then all Code Factory has to do is prove they sent you the email with your license key to stop any refund request.

That's why, when I can, I use my debit card instead of PayPal. That way if there's a dispute such as a license key that won't work, I can go to my bank, fill out an affidavit that I didn't receive the goods I paid for, and in a business day or two my money is back in my account.

Sure, at that point CF will get a charge back notice on my order and will mark the key as stolen or refunded or just plain invalid, but at that point I won't care because I'll be looking somewhere else for Eloquence for SAPI.

Never the less, I wish you much luck in getting your issues with CF sorted out or you get a refund.

Thumbs up

95

i installed jake gross's sapi5 eloquence, it crashed my screen reader and games. tried uninstalling it and it said it could not unregister a bunch of stuff. messed up my sapi5 bigtime so it was useless. i had to completely reset windows10 using microsoft media creation tool telling it to wipe everything and keep nothing throw it all out and start over. I really like my new laptop. got it for $250 on amazon. its an hp 15.6 inch notebook with a number pad on the right. it has System Information
Current Date/Time:Sunday, June 18, 2017, 2:47:44 PM
Computer Name:DESKTOP-G483G6F
Operating System:Windows 10 Home 64-bit (10.0, Build 15063)
Language:English (Regional Setting: English)
System Manufacturer:HP
System Model:HP Notebook
BIOS:F.22
Processor:AMD A6-7310 APU with AMD Radeon R4 Graphics     (4 CPUs), ~2.0GHz
Memory:4096MB RAM
Page file:2149MB used, 2745MB available
DirectX Version:DirectX 12

Thumbs up

96

And that is why, as much as I'd love to ditch the Themedia DRM, I will keep using the protected version. So far, fingers crossed, it hasn't crashed or done anything unhealthy to my system.

In fact, besides the DRM, the only bad thing I can say about it is the time it takes the DRM to validate my license. But even that isn't all that big an issue because the only programs it affects are games.

Everything else is either self voiced, or uses JAWS which is quite responsive.

Thumbs up

97 (edited by coltonhill01 2017-06-19 02:33:56)

I have not seen sapi5 eloquence crash me. What might be causing it is permission errors of where it's trying to put the files. It tries to put things in some directories under either windows or system32, both of which are protected. If I remember correctly I had to take ownership of the directory to actually get it to work. I haven't tried it since I installed it just recently after full reinstall, but I'll check and get back to you on the permission thing. The installer did yell at me the first time it tried to install it though and got that error.
Edit: yep, it works just fine here. Check under C:\Windows\speech and look for an eloq folder. If it isn't there, you have permission errors and should take ownership of C:\Windows\Speech and add yourself a full access permission before installing it. Hope this helps.

----------
Best Regards
Colton

Thumbs up

98

Specifically, how do you take possession of a folder. There have been times where Windows has asked me if I wanted to take possession of some folder, but I have never figured out how to invoke it on demand.

And where did you get the SAPI Eloquence you're using?

Thanks!

Thumbs up

99

download this simple registry hack
There are two files, one which adds the value to the registry and one which removes it. Run the registry key to add take ownership to your context menu.

I'm the only adventure at c: master hahahaha I have unlocked just about everything!

Thumbs up

100

There's no problem sharing this kind of file here?

Thumbs up