1 (edited by pulseman45 2017-03-16 08:31:12)

Hello everyone,
I have a problem with foobar2000. It seems there is a default track duration that is set to 3 minutes. This duration is allocated by default to tracks in certain chiptune format such as NSF, GBS or SID.
The problem though, is that certain SID tracks I listen to are longer than 3 minutes. So it will end automatically before it is supposed to. Is there any way to fix that or do I have to use a dedicated SID player?
I use SIDPlay2 v 1.36 to decode this format.
Thanks in advance for your help,
Pulseman

Thumbs up

Hello there,

I don't know the exact answer to your question. My problem, which has been solved, was the incorect length of some of my mp3 books and radio plays. I understand you can't do it with .sid, but the way I fixed my problem was rebuild the mp3 header. Then, the duration shown was corect, and the files play properly. Since I have some .sid's, I'll download the plugin and check it out. Sadly, I'm no IT specialist, just a Foobar user, so maybe someone else will know the exact solution before i do.

Regards,
Rok

Thumbs up

3 (edited by pulseman45 2017-03-16 10:22:56)

Now I have a bit more information at least. What I have is the High Voltage SID collection. In that collection there is a file called SongLengths.txt. Apparently there is some way to use it so Foobar2000 aknowledges the correct lengths but I couldn't find the exact way.
Edit: It's solved. I found the answer on a german forum. The thing to do is, in the preference dialog, to go to playback/input/sidplay, and to add SongLengths.txt to the database status.
Sorry if it appears as disturbing as I finally found the solution myself. Basically when I wanted to find about changing the default duration, I couldn't find anything. Still I hope it may help other people in the future.

Thumbs up

I was going to try to answer your question, but since you figured it out, I'll just add that the GME plugin has a similar setting for some files that it can't figure out IE NSF where some famicompo entries are definitely longer than 3 minutes. In that case, since there is no song length database you have a global setting that you can increase and if something is shorter than what you put in the song will just loop.

The twins of Mammon quarrelled. Their warring plunged the world into a new darkness, and the beast abhorred the darkness. So it began to move swiftly, and grew more powerful, and went forth and multiplied. And the beasts brought fire and light to the darkness. - from The Book of Mozilla, 15:1

Thumbs up

5 (edited by pulseman45 2017-03-16 13:33:11)

Yes, I thought it could be like that for other systems, though I never encountered the problem on a gbs/nsf, at least not for now.

Thumbs up