Judging by the packs i've seen for games like Cosmic rage and six dragons, absolutely fine, though I'm not really the person to talk to about scripting in the game.

Thumbs up

So, I've taken a new character through the newbie area, and I have this to say:

1. I feel like the area has been a little bit streamlined, and I found the clue I missed before regarding the captain's name.
2. As far as greetings? Um, you can get that info any time you want by just going back through the school. You don't have to restart or anything. For future reference, the general greetings are "Hail" for prehistoric, "greetings" for medieval, "howdy" for wild west and "may the force be with you" for future. However, take note: there's a sort of mini newbie zone just outside the actual school that has an old west theme (you'll know it if you're on a ranch) and for some reason the NPC you have to talk to says "greetings".
3. If you do all the tasks you're given, you will have more than enough exp to get your first remort, which is cool. Because of the way I planned it, I'm going to actually get all the way to my second.
4. There are some downright fiendish puzzles in a couple of the newbie areas. The robber baron's castle, for instance. That one hung me up for quite awhile. If you're stuck, just remember that not all things are what they seem. A creature can be a container, or a container can be a potion, or whatnot. Won't say more without spoiling it.

Now I'm at the point where I have to wait for an immortal to help me out, because I've done all the tasks, and then it's on to wondering where exactly I go next. I'm going to give this one an honest try, though I still don't like guess-the-syntax, and I can tell that some of the builders here in the past are fine with that concept. So we'll see how it goes.

Thumbs up

@JAyde, my problem was I assumed that when it says that the quest academy if you asked for a solution you'd not get the quest it was a one time only thing and if you didn't get the solution that was pretty much that.
I know however now it's possible to go through the quest academy virtually as many times as you need to up to level 50, so no, I didn't need to restart, but hay it doesn't matter as I had an easier time through this time around.

Two things I do like already are that firstly your hold location for wands and such doesn't stop you using a weapon, and secondly the way ranged weapons work, since it's really cool to be able to hunt around for stuff in nearby rooms, though I get the strong impression in this game that mob killing and levelling is almost an afterthought.
For what next, well there do seem to be directions on the quests.
See  This page on quest cards from the old 4D site
I believe these are also available in game, and these, plus the professions are probably where I'm going to start looking when I've finished all the newbie tasks.

As to me, I have however run into one miner snag, but I don't know if it's a bug with Vipmud or 4d itself.

Beware! spoiling spoilers of spoilage ahoy for quest academy!

I've found everything in the mudschool and quest academy accept for the helper voucher five.
I even think I know where it is since in the parlour is a painting with a lady that winks at me.
The problem is whenever I examine that painting Vipmud gives me an error.

I've tried wink, and also tried saying things in case the lady in the painting actually talks, but I'm not sure.

I'll go and double check since there were two other cases of odd objects in the academy, but if it is the painting an idea of how to work around it might help, since having to log back in each time is a miner pest.

Thumbs up

mild
spoilers
Nope, it's not the painting, so you're not stuck there.
As a hint: try using your other senses.
As a second hint: It's after the maze.

I really had to work to find this one.

Thumbs up +1

Thanks Jayde, got it now.
Btw, thumbs up for perfect level of hintness, actually I'm kicking myself for not trying that big_smile.

Now it's off to the newbie area to continue with the tasks.

Edit: okay, been to the newbie area and I'm stuck on the first zone.

beware! spoilers for newbie prehistoric area!

IO'm in the prehistoric area, and what's annoying me is there are virtually no embedded objects there so no sign of the flag.
I've found the hunter who asks for a weapon, and I've found the seedling maple tree that glows with an innner light.
I can't take it, I can't get anything from it, I can't smell or touch or feel it, or look under it, indeed it seems pretty dam difficult to interact with, but since it's the only bloody thing I've found! to interact with in the entire map besides lots of mobs, the hole back to recall and the hunter himself I can assume it's the right tree.

I confess this is the mildly annoying type of puzzle where I have found what I think is the right object and just can't do anything with it.

Thumbs up

I can't remember right off the top of my head where the flag loads.

And as far as the guy you're supposed to help, it looks like a needle-in-a-haystack hunt, but it's not.

slight
spoilers
Hint: He can't do it, so maybe you should.

end
spoilers

Me, I think I'm gonna give this mud a pass after all.

First of all, it turns out that if you do all the tasks, you get a free pass to level 50. Unless you hit level 50 beforehand, which I did, in which case you get a silver token. I suppose this isn't bad.
Except that it leaves me around level 8 and without any idea whatsoever on where to grind. The few quests I was pointed at were dead ends. One is to find a nymph or something, and I wandered into a nearby area and was two-shotted by something. Another quest is arbitrarily level 25 even though there's no combat (the riddle book). So, uh, this is what I remember from the mud. Loving the first few areas mostly, then feeling utterly and completely cast adrift.

Thumbs up

Hi Jayde.

Ah, it turned out the problem was that the tree was randomly generated. apparently there's an experimental new craft in the works called wood singing at that's what the tree was for, it wasn't part of the quest.
I get the feeling their doing a site redesign at the moment which makes info a bit more up in the air than it would be normally but there is  This page on the wiki that lists areas and levels.
I get the idea in 4d that because of their remort system players increases in power are sort of temporary, you need to be a little more careful with respect to areas and levels and what you wander into, but you can always go off and train stuff or trade or whatever until your ready for an area that a given quest is in.

I have seen quest discussion on the gossip channel, so it doesn't seem that quest info spoiilers is a no no so long as your careful.

Also, it seems this is a game where combat is as much about what random other stuff you have as about what your stats and equipment are, eg, using ranged weapons, staves, grenades etc, I actually do really like the way that your hold location isn't the same as your shield or weapon location, meaning it's possible to have a staff or wand in reserve for tough battles.

Thumbs up

Okay after lots of running around and hack n slash on aardwolf I was in the mood for something a bit more interlectual and decided to give this one another go.

I finished the newbie zone and did all the tasks though didn't get anything for it which was a might disappointing.

I am now trying cooking since some of the trades look interesting.
One thing I will say is this game has some really awesome vi maps, even down to areas like outerspace, and people are good at answering questions which is very nice, although I do find some of the syntax for some activities a bit irritating (I couldn't get racing sorted since I didn't know how to equip items onto my horse and the sign just saying "saddle horse" didn't help.

One thing which does look nice is the fact that trades in this game are far more about exploring, eg, to cook you need to actually find ingredients for which you need to wander around, as well as do tasks like churn milk into cheese, farm vegitables, get filets of meet from corpses etc.

I am not sure et how much in terms of things like plants is randomly generated and how much you need to explore, but I do like the fact that the trades really do give you something to do besides mob murder.

Btw, speaking of mob murder, one thing I do notice is that each time zone has suggested newbie areas such as the royal forest in medieval or the game grid in future.

The only major problem I have is comparing items and knowing what gear I should use for what, though as I'm concentrating on trades right now I haven't run into anything too dire.

Thumbs up

Okay I am afraid my last experience is far less positive.
Since I fancied something with less mob murder I decided to try cooking. So I found the person giving cooking lessons and was told to prepare a recipe.

First thing to find eggs. Okay, the trade info tells me the chicken farm with eggs is, however are there eggs there? are there buggery! and nobody on the game seems to know.
I did manage to some milk however then when I tried to scrape the hides of the cows to earn some cash the scrape command just plane didn't work, I wielded the knife and held the hide as the directions said and I was told "you need to hold the ihide" I tried with several hides and another player tried, ti worked for him not me.

Finally, I try to register on the forum to let people know about these problems, and guess what? the audio capcha doesn't work, and I'm told I didn't get the verification right either.

I'm sure there is a great game in there somewhere, but honestly this one seems so bloody buggy and I don't think there is anyone to actuall tell about the bugs.

what is the real shame is the bugs seem to exist for the trade skills, and yet the trade skills are potentially some of the most interesting parts of the game.

Thumbs up

Okay more info on said bugs.
Yes indeed they were bugs, now however I submitted a bug report and they are squished.
One thing I wil say about 4d is that while they don't have many players on at a time, the admins are very responsive to info about bugs etc, indeed now I'm getting on better now I no longer have to mess with those bugs.

The one thing I will say is 4D really is! a game where you need to look at everything, even with things like crafting, for example examining a bag of wheat tells you where the mill is to get it ground into flour, then examining the flower tells you where the baker who will buy it off you is.

So, I'll persist with this one for a while, and I can advice people try it, indeed I'll hopefully be getting a db page up for it soon.

Thumbs up

The best gear is from quests.

Quests have weird syntax, and in many places you aren't told even who starts the quest, so you may not be able to do much.

You're told to look at everything. But there's a girl in an area I won't name, who when you look at her it says she's very worried and might need help. I've tried every greeting, and pretty much every permutation I can think of including the words "help", "what's the matter", "worry" "worried", "aid", "lost" "find" "need"...nothing works. She won't talk. So...um. The syntax is probably something crazy like "Excuse me, miss, are you in need of assistance" but the game doesn't tell you this.

In another completely unrelated area, you are sent on a quest and given a clue about some street urchins. I spent seven hours (I'm not kidding here) running around the area doing everything I could for these urchins, and nothing worked. Only to later be told "Oh no, the urchins don't matter, have you found so-and-so yet?". Well of course not. the quest told me to investigate the urchins.

So I eventually got a little help and figured that latter quest out. And it's not bad once you get rolling. There are some good bits of story and whatnot. Though there are other issues with syntax. For instance, in a warehouse stacked high with crates, you actually have to "look crate", not "look crates", which is extremely nonintuitive.

Dark, I've been skinning/scraping hides for weeks. I don't know what bug you had there. Maybe it's been introduced in the last few days? But you have to make sure youre leather knife is wielded and your hold slot is empty. You type hold skin, and you'll get a message like "you grab the sheepskin", then you type "scrape", and it'll start into a thing where it tells you what's going on. Royal Forest is really excellent for levelling, as it's full of sheep whose skins you can tear off for exp.

I stuck around on this one long enough to determine that the game's few remaining players are more interested in hoarding their knowledge than on retaining players. It seems more important to them that everyone has to work exactly as hard as they did on quests. With very few exceptions, if you ask even for a tiny hint, or where to start a quest, you'll be either ignored or told off. I'm not looking for hand-holding, but I don't like a community that prides itself on that sort of cliquishness. Sorry. I gave it up, and I really won't be going back unless or until I can either 1. find a source of quest info that I can look up when and if I get stuck, or 2. the game's policy on qinfo is relaxed. Like I said, I don't need a hand-holding walkthrough. I'm decent at quests. But when I'm in a 200-room zone with deathtraps that could destroy all my gear, with mobs that can do a ton of damage and with all kinds of items, and when I'm not told even who to talk to, that's kind of deal-rreaking to me. I think nearly every quest should give you an idea of the start point, even if it doesn't tell you what to do.
A quest is neither fun nor rewarding when it's just sitting on a server collecting dust, not allowing players to finish it. You aren't a good builder just because you made a quest that only 29 people ever solved. Sorry, but this is ridiculous. I wish you luck in your endeavours, Dark. Maybe you'll have better luck than I did.

Thumbs up

Hi Jayde.

I've found royal forest, and yes, the girl is annoying, though I wonder if your supposed to give the bits of the map to her since they're written in another language.

I do think in fairness since quest trackng journals is a recent update some of the obscurity with quests is being worked on, indeed you might want to email the game's developer about this particularly because I am unfortunately experiencing the same ignoring issue, eg I've asked five times how to bundle skins so that I can sell them to the trader who needs rat and weazle skins and people are plane ignoring me.

Since the main developer was herself very communicative, about the bugs etc I might send her a link to this topic with your comments, since I do if something will drive me away from a game obscurity might actually do  it too since I love story and questing, but lack of progress and no way to progress due to guess the syntax is down right irritating.

the sad thing is I do think there is a great game there and at least a developer who wants new players who aren't put off by obscurity.
I might

Thumbs up

The game is also littered with typos and weird syntax in combat. I feel like combat has been given the very basic treatment, and it sseems to be about 90% stock rom. That's not a game-breaker, but it'd be cool if classes played differently from one another. They don't. If you pick a warrior or thief class, you will probably be kick-spamming for your first few remorts. This is disgusting.

Oh, speaking of classes. Physical claasses (warrior, hunter, thief, gypsy, ranger) can't do damage to all mobs in a room. Priests, espers and mages can. Not only that, but it seems like the sheer damageoutput they have is far and away above the melee equivalent. Melee chars are a bit more tankish, but the overwhelming opinion on the game seems to be that you pick whatever of the non-magic classes you want for your first five classes, then finish off as a caster class. I had mastered thief and was a tier 4 hunter before I just dropped my account and left.

Some players on the game (one named Maco, another named Kitolani) are actually quite helpful when it comes to non-questy stuff, and Maco was the one who told me not to worry about urchins. So it's not all bad. And some quests do give you hints, or lead you gently. I'm not at all opposed to tricky/difficult quests. But knowing where to even begin a quest would be extremely nice, especially in large areas (Enchanted Lands is the one I referenced earlier, with the deathtraps and all the items and such).

So yeah. The game is...how old now, and still has very simple-to-fix typos in its combat. It's hugely caster-oriented. Crafting really is interesting and gives an alternative way to gain levels, which is good because the grind gets very, very, very dull. But the tiny player base seems to speak for itself. As I said before I took off, there's a reason the game appears to be so small. Elitism doesn't work.

Thumbs up

Again since I get the feeling the game is trying to expand these are probably things to report.
I will confess I was a little pissed off when I mentioned the no eggs in the chicken farm bug and was tol "misdirection ha!" by someone on the channel, particularly since it wasn't actually misidirection it was a bug in the code.

Since however the admins at least do want to expand things and a working quest journal system could help I would encourage contacting the admins before chucking this complete.

I will say the crafting and other aspects are what to me look far more interesting than the rather stock combat, since hay right now as a ranger all I'm doing is running around typing kick and snare. Then again ranged weapons are a thing and once I get one that is actually decent that might be something to try, although these days I don't generally look for interesting combat in muds so much as interesting other stuff.

Thumbs up

eWell again I seem to be changing fortunes with this mud.
No answer for a couple of the quest mobs, but on the plus side I did solve some of the farming problems.
One of the issues, particularly with crafting I think is that often what you can do in one area isn't necessarily reflected in another, or at least you need items from one place for another.

I don't meanquest elements, I mean obvious things.
a
For example, the medieval zone doesn't have anmilking stool and pale available for milking a cow, or bundles for trading skins, indeed when I saw people talking about "bundles of skins" I was genuinely confused, since to me "bundle" sounds like a pile, but it trned out bundle is a container only sold in the old west I didnt' know.
Again though, these are things which a quick report can help since they're either A, not putting the necessary crafting items in more than one location, or b, problems due to simply less than adequate information on where basic things are.


Edit: okay there is one other fact I didn't know, a lot of the crafts particularly have books to go along with them, which you can find at the relevant crafting shops, the problem of course is finding the relevant crafting shops which is interesting in itself big_smile.

Again I've had some great responses from the admins on this and the access features are extremely good (I was especially well impressed with the space map commands when your flying a spaceship).

And I suspect this is one game where just a little information can get people started nicely.

Thumbs up

And again more information.
One thing which is impressing me, is the fact that the developer is very welling investigate bugs and issues with things like quests.

when I pointed out the problem with the girl in the forest, she (the developer not the girl), immnediately went to look in to the situation.
I actually get the feeling that in 4d beta testing of areas is possibly not as complete before they go live, so it's up to players to report bugs and issues such as misdirection which builders might have missed, however in credit to the 4d staff once these are pointed out they get fixed in short order, and as I said there is definitely a good game in there ---- though mostly due to all the none combat stuff.

Thumbs up

Okay I went back to this one and am actually doing better now, I've actually finished a couple of quests and I think I am getting a better idea of how things work.

One thing I will note is that this mud has an unusual number of examine commands.
Search (which frequently needs to be done multiple times), as well as look behind or in objects plus smell and listen.

Generally if a command is obscure a bug report will let the admins work out what is happening with it, indeed often a bug report will give a note on how to do the quest. For example when I reported the business in the royal forest with the girl they were quite happy to fix her response to "help" as it is for other mobs who say they need help.

Other players generally aren't aversed to giving hints, however bare in mind everbody has done all the quests, often the hints are more in the matter of letting you know specific on how the mud works, for example in a recent quest I having trouble because I couldn't find where to progress and it turned out all I needed to do was search in a room I hadn't searched, indeed the clue was there I just hadn't followed it so when I was told "to search every room" it was good advice for my situation even though it seemed more like generalized advice to me at the time.

To illustrate I'll give some quest directions to the quests I've done so far.

The royal forest:

there are a couple of things to do here such as giving wolf ears to the ranger and returning a shepherd's lost sheep, but since those are fairly obvious just by looking at the mobs I'll leave those for people to find.

The main quest involves a girl who needs help and a lost map, indeed I found bits of the lost map before I ran into the girl.

The girl tells you her father the game warden is missing and asks you to take him his clothes, and gives you a bundle of clothes.
Examining the clothes tells you that the warden's name is gerard, which then clues you in to the fact that he is not the same as the forest warden who accepts the wolf ears.

Doing "where Gerardd" points you to an owl in a nest. If you've explored the area you will know where this is, if not, go to the northeast corner of the area and you will find an oak tree mentioned in the description with a trunk going up to the sky.

"climb trunk" will get you to the crown of the oak. Reading the room description will lead you to a hole with a nest.
Now here is the complicated bit. In the hole you'll find an owl said to be intelligent. You know if you've done "where Gerard" that this owl is Gerard and if you read the description the owl is said to hoot that literally sounds like "who"

So "say Gerard"

The owl will turn back into Gerard who was under a curse and he'll say if you want help with finding your way around the forest come to him. It was fairly obvious to me "since I'd already found pieces of the map" that Gerard was the guy I needed to talk to to get the map solved, however here is where I got a little lost since I couldn't find Gerard. I ran into him by accident in the grotto which is at the end of the path that runs north to south through the area.

The map itself is in four pieces.

you will find one if you go west from the "crown of the oak" (where the hole is you enter to get into the owl's nest), and look at the branches, you'll be told "something is caught in the branche"
One of them you can find in a glade in the forest close to the southeast corner where a fallen tree is mentioned (look in tree).
One is in the lake with the ducks, go "look duck" and you'll find a ducks nest you can look in, (if you go one room east to the dark part of the lake and look under the water you'll find a tangle of branches with the zone flag).
And the final one is actually in the grotto next to Gerard in the donation box mentioned as on the wall.

Give Gerard all of these bits of map and he'll tell you it's the map to some robbers treasure.
He'll tell you pretty clearly where the treasure is, but if you are stuck it's in the same room as the oak you climbed to find the owl in the northeast corner (go to the northeast corner, look gap and then enter gap, you can't do this until you've got the map).

Hope this gives people an idea of how things in 4d work.
I'll also write up a brief walkthrough for Alibaba's cave too since that one has more of the complex examining commands.

Thumbs up

Okay Alibaba's cave.
can find out about this quest with the qlist commandor by going to the quest card machine and typing card 118. These are how tyou get clues about quests.

As to the cave itself this one is an interesting one.

To begin, you'll have to go to old carthage excavation camp and then go east from there and you'll find yourself in a desert.
this is a maze rather like the one in the newbie academy. There are various mobs to kill like snakes and such, but the ultimate goal is findin your way out.
somewhere there is a room with a nomad digging, a rock and a plaqe that tells you a little about the cave.

I don't recall exactly the directions here, but if you use the smell command you should find a room that smells of water, go south from here and you'll find an oasis (that is assuming you don't just run into the oasis as I did).

Now here is where I had to learn a command, since in the oasis you need to use "look direction" to find out where to go.
When you find a ridge to the east you can climb the ridge.

Now if you explore the paths you'll find a dying man who tells you that the only way of getting into allibaba's cave is by disguise. So find a thief and kill him, (there is one in the thieve's lookout).

Now, wear the thieves galabaya and go and fin huge stone that blocks off the cave (I believe it's down the east fork of the ridge),  the stone should tell you what to do here, though to be honest anyone who has ever heard the legend of Alibaba should know this part.

Now hopefully your in the cave, and it's actually smaller than it seems. Looking in the earns can get you both food, but also disturb some sleeping thieves who are agro, but easy to knock off.
go south until you get to the central hall then take the east passage.
If you explore there you'll find the stables, however exploring north you'll find the dungeon cells with a convenient gaoler.

Do I need to explain what to do here?

Onc eyou have the cell key, checkout the last cell and greet the man in there. note that what you need to say in conversation is fairly obvious, eg, when he asks you if your joining the thieves say no.

He'll then give you some directions if you find Alibaba's office.

Now go back to the central hall and head to the south.
Go through the armory and up to Alibaba's bedroom and search. note that in 4d you often need search several times.
You'll find a south exit, go through there and you'll find a secret passage with a sandal bag. Take the rusty key from that bag and either retrace your steps or search again then go east into the stables.

Now, you need to find Alibaba's office and of course it's west, from the central hall, indeed in the direction of laughter should you use listen.

If you explore south you will find a potter's workshop and south and west finds a kiln, this is a proto deathtrap so avoid it.
Exploring north however the dining hall. if you read the description you'll find a west door, go through here to find Alibaba's office and sure tenough if you check behind the portrait in there you find some directions.

Now here was where I made a miner mistake and got matters wrong, since actually the directions you get are dead accurate and can be followed from where you are provided you search for hidden exits a couple of times.

I however didn't realize about the need to type multiple searches and so went off exploring, which was fine, but didn't tell me how to complete the quest. However if you search in this room, then in the next few rooms along those directions you'll eventually find your way to Alibaba's treasure room and a meeting with the man himself big_smile.

hth.

I am getting the strong impression that the quests in this game are! fair, or at least are intended to be fare, but do require searching and making full use of the mud's parza for examining things, and hopefully these should illustrate things a little better.

Thumbs up

Just wait till you find Victorian London, Dark. You will pull your hair out with that one, I bet.

I've done Ali Baba's cave, and I found all the map bits in Royal Forest, I just couldn't get the girl to talk so I had no idea where else to go. I also did the wolf-ears and vermin-slaying bit.

Did you ever catch the escaped cougar in the same area?

Thumbs up

Well Jayde, if you use qlist you can get the quests by difficulty which works rather well and as I remember the victorian london quests were listed as harder so I'd probably look at those later down the line.
I never got the cougar, but that was more because I wasn't exactly sure how long to wait once I'd bated the cage.

one thing I will say, is that the admins are great at fixing actual inequities. For example now the hunting file lists the fact that you need bundles to sell skins and where to get those, and the girl in the forest will now respond to the word "help" (apparently before you had to type what's wrong).

4d really is a game I find my opinion of changing very rapidly since either I find myself absolutely loving the writing and exploring, or I find something that is unclear or obtuse, or I get stuck on something obvious and kick myself when I find out where it is.

For example the latest thing I tried was the grape harvest on planet lavenbroi. The help file says I can go there and do grape harvesting and wine making as a craft activity, however when I go there and look at the vines the description says they're full of grapes but the vines themselves as containers are utterly empty, it's down right confusing!

It's a very odd game in that respect, but I do get the idea the admins are working to make things more coherent and logical when there are actual inequities like that one.

Thumbs up

I could never find bait for the trap, so I left that quest behind. That's why I asked.

Victorian London is considered medium, not hard. There's a second area of Victorian London (commonly called VE2) which is much harder. I didn't even touch that one.

It's really odd how that works for you. I mentioned the issue with the girl in Royal Forest weeks ago, and I was told to just look harder even after I brought up the problem. I wasn't rude or aggressive or anything, just pointed it out, and got no results. Yet you can do the same thing, and you get feedback. Don't understand that, myself.

Victorian London is an area where you really don't have to fight much, and the rewards are very, very good, so it's definitely something you should look into. If you do try it and get stuck, I'm willing to give hints. I don't just want to drop a spoiler bomb on the whole area, as that never really does anyone any good, and I daresay that if you're at all like me, then you want to do everything you can to figure stuff out, and not just have a walkthrough to follow.

Thumbs up

Well using the "bug" command is a direct line to the admins ad things like the girl not responding is the sort of bug they fix.


In terms of the player's gossip channel, that is one of the problems I did notice, sometimes when I mentioned a specific issue they'd respond, sometimes I just got the generic "look at stuff, read the help file" type responses, though generally whe players know you they're a bit more reasonable I noticed, and as I said I think the admins are bent to have quests be fair,---- not easy, but fair, hence why I reported the issue with the grapes because it is listed in the crafting help file.

Thumbs up

I just gave the mud a try today, and absolutely love it. For those who long for soundpack, I think I'll consider making one for 4d. And it's gonna be buggy as uaual lol.
I'm Sereas in the game. You all feel free to poke around if you find me on. The channel history thingy is already coded in, sure is a good start right?:)

Thumbs up

Cool MArta. I'm unsurprisingly Dark on there if you want to look me up, though i confess I've been having a miner break from the game for a bit as I got a little mudded out since I've been playing several recently.

Thumbs up

I get seriously stuck on the voucher from the future grade zone right now. Can't find it for the life of me.

Thumbs up