201 (edited by daigonite 2017-06-19 17:22:38)

This is an early release intended to demo the new audio engine. I need to do a lot more work in other parts of the game but I wanted feedback.

The controls are slightly different. To drop down a bookmark, press shift. Press shift near a bookmark and the bookmark menu opens. You can either rename the bookmark or delete it. The rename screen is super basic right now.

You can open the bookmark list with E. Both the exit locator and bookmark list allow you to create an audio path from your current position to the desired position. Press z to create one and c to destroy all paths. The path is a sound that will move in the direction towards the destination. If you go too far away from it it will be quiet.

The next full release will update the tutorial accordingly, just takes a lot of time to put that stuff together tongue

https://drive.google.com/open?id=0BygzF … U03RkliTkU

You can't turn off the sounds just yet but the other functions are pretty much working so give them a try.

EDIT: New game is broken, will fix tonight.

Thumbs up

202 (edited by threeblacknoises 2017-06-20 00:43:25)

Hay Daigonite, I saw your post, but couldn't check out the demo until just now.
Here's what I've found so far.
first of all, before I remove this from my clipboard, I got the following when I tried to get to the party menu.

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Alarm Event for alarm 11
for object overworld_party_main:

Push :: Execution Error - Variable Index [0,-1] out of range [1,24] - 101115.friendship_values(100099,-1)
at gml_Object_overworld_party_main_Alarm_11
############################################################################################

Okay, now that that's out of the way...
I like the tones when approaching a wall as well as the echo of the footsteps when approaching a wall.
I do think we should be able to choose the kind of notification we want though, as I can see one type being preferred over another for some people.
I also like the sound that plays when a wall disappears.
One thing I've noticed though, the speed of the footsteps doesn't match how fast the character seems to be walking.
In the first tutorial, I noticed that my character was walking at an angle, as my X position was changing when I was walking down as well as to my right or left.
Anything else you'd like me to test?
Edit; I just tested the bookmars, and, they don't work at all.
Pressing shift does nothing, and pressing E produces the menu exit sound, along with this.

___________________________________________
############################################################################################
FATAL ERROR in
action number 1
of Create Event
for object bookmark_locator_menu:

trying to index a variable which is not an array
at gml_Object_bookmark_locator_menu_Create_0
############################################################################################
Well that's all for now. Sorry I couldn't be of more help...
Later!

Thumbs up

203 (edited by daigonite 2017-06-20 10:47:23)

Just updated the link, it fixes the second error at least. Link is here for people who don't want to search for it: https://drive.google.com/open?id=0BygzF … U03RkliTkU

Not sure why bookmarks aren't working. Try pressing shift twice. If a bookmark was actually created, it will open up a menu. It could be that the sound is not playing as an error.

Also, try pathmaking, the access locator menu still works (W key) and you can create a path by pressing z. also can delete the path with C in this menu.

Thanks for helping, this is an early release and helps me catch bugs for the next "actual" release lol

Thumbs up

Hay Daigonite, I just tried the new link, and the bug is still their; even though I did try pressing shift like you told me to and nothing. I did; however; find another bug by accident.
If I press the W key to open up the landmark menu, I can still press the enter key and open up the main menu.
When in this stage, the game still reads the landmark menu, but pressing Z activates the option on the main menu instead.
In my case, it brought up the party menu and my game crashed with the error I reported yesterday.
One final thing, When the name screen is displaied at the start of the game, I can move around with the arrows as if I can select letters and type them in like I'm in an old name screen from the nes, but if I press Z I type the letter z instead of the letter I'm on.
Also, I can't enter capital letters as shift reads the name field.
The game reads the input field after every letter I type.
Well, hopefully we can get all this stuff fixed so the game can start to be plaied...
Later!

Thumbs up +1

205 (edited by daigonite 2017-06-21 02:16:10)

No no no, I wanted to know if you pressed shift twice if a menu appeared. I meant that I fixed the crash with pressing E. I'll be taking a closer look tonight.

EDIT: I cannot for the life of me replicate the bookmark bug you're experiencing, can I have some more information about both your operating enviorment and about what exactly happens in the bug? Also, try moving a few steps and seeing if the sound returns. Also, pressing shift twice in a row in the same place should open the bookmark menu, does it NOT do this? If it doesn't the bookmark isn't created, if it is, the sound is mute.

I know what is causing the other bugs and I'm currently addressing them now.

Coordinates are not 1 to 1 with footsteps if that's what you're wondering about that. Its just the literal scale right now. But I may scale it more appropriately later.

Thumbs up

Hay Daigonite, I tried what you said with pressing shift and walking a few steps. No menu, or wind sound, or anything. Oh, I'm on windows 7 by the way.
I tried the W menu, and things seem to work their, but the wind sound used for paths seems to cut off before restarting. Maybe an accidental bad loop or something?
Also the text for the blackout mode tutorial doesn't always work.
For example, the opening text never autoplays, and so I thought I was just in some debug room or something, seeing as this is an early demo.
I tried the bookmark thing in the actual game and it still doesn't work; good job with the remade music, by the way.
I did notice a delay after leaving the first house before mark showed up though.
Oh, and I posted this early this morning, but had a dirp moment, as I alt f4ed out of the internet before hitting the post button.
Later!

Thumbs up

207 (edited by daigonite 2017-06-22 15:17:56)

You're the only person reporting the bookmark problem. I tested on 3 other computers and bookmarks were being created properly. Were they working before? I'm going to update the link tonight hopefully with a debugging feature that will allow me to diagnose what exactly is going on.

The way the path sounds work is they follow a path, so when the path resets, the sound "jumps". I decided to keep it since it indicates where the path ends are.

I'll also investigate what causes the delay but it won't be fixed in the next update. Thanks so much for your help and patience on this issue.

Thumbs up

Hay Daigonite. I dug up the latest demo you posted on, that nd site, and yes, bookmarks work fine in that version, but not in the new one... odd.
Also, where is the game saving it's files?
I have the old demo, and the early one you keep updating on google drive, but I was able to load my save game from yesterday on a clean installation of the old demo, even though I had to go and set the accessibility flag on the old demo after extracting it to a different folder than the early one.
Later!

Thumbs up

username/appdata/local/colors/savegame.ini   is what you're looking for.

Based on what you're describing, it's almost as if the object isn't being created. Perhaps it's being created on another part of the map as well. I will be adding some stuff but Game Maker's most recent update screwed up my graphics a bit so I have to check what's going on with that as well.

Thumbs up

https://drive.google.com/open?id=0BygzF … U03RkliTkU

Alright ThreeBlackNoises, I have a debugging element added that will allow me to see a bit more information. It will be stored in

username/appdata/local/colors/debug.txt

since I have not mastered the fine art of doing this stuff online yet lol. Sorry for the lack of immediate updates, been both aloof and busy as hell neutral Please try to set down bookmarks several times in several places so I can get a better idea of what's going on. Thanks.

Not being able to use bookmarks should not destroy the experience but will certainly hinder it so I want to make sure I cover this base. In all honesty I have no idea what's going on lol.

Thumbs up

Okay, I just downloaded the new version, and everything's working now.
Multiple bookmarks work as described, and the menu works to, so yeah. I guess you fixed it lol.
Later!

Thumbs up

well that was weird. Well, time to resume the stuff I'm doing for the visual mode.

What is your opinion on the new bookmarks system, any suggestions?

Also, is the current format where stats are given to you (giving you all the numbers) too much? I noticed when testing with sighted demographics this was too excessive, so I built a casual mode, but since the casual mode uses graphs to show information that's usually represented by numbers, it might be a bit tricky to convert into blind mode. So anyone with any input would be really appreciated.

Thumbs up

Hay Daigonite, I think I found the bug for the bookmarks, but I have no idea how you'd fix it. When I'm in the tutorial mode, the bookmarks don't work at all. and this carries over when the game starts. I had to use escape seeing as the bug won't let me finish the tutorial, but when I reboot the game and load my save, everything works right.
As for what I think of bookmarks, I can see how this could help, but I can't see how you'd find out what bookmark you're at unless we can enteract with them or sapi speaks the name of the bookmark as you pass it.
They do save between maps and even record in the save data, so that's a big plus for navigation aids.
Regarding stats, are you refering to the numbers I get on the main menu when I press q or w?
If so, I have no idea what these numbers mean at all, but it I did, or if you separated each stat with a comma, they'd read better.
I did; however; find a bug that might be why the character menu keeps crashing the game.
If I press w for mark's stats, the first value is FF instead of 0, So, yeah.
I hope this helps out in some way.
Later!

Thumbs up

I like the idea of having the name of the bookmark being read when you pass near it.

The names aren't saved yet by the way, but I should have that done by next release which will be in July.

Also, I'll have to look into the problems with the tutorial. They need to be completely redone due to the upgrades.

Regarding stats; I will have to build a tutorial for those then. I might add a 'shift-character" function that if you're pressing shift will read off what that stat does.

The crash was due to iirc something that was referenced when it shouldn't be. Red's color is actually FF 00 00 so having it say FF first is accurate.

Thumbs up

I found what you were talking about with the error to do with the party. Actually has to do with new UI elements I put in, only would work if the party has 3 characters in it. Don't check the party until you have Mike in this version. I'll be uploading a new official version within 3 weeks so stay tuned.

Thumbs up

https://drive.google.com/open?id=0BygzF … ERxZEtFVzg

This is the early release; I will be doing a full release in the week of July 24th. Please please please notify me of any weirdness, I can't make any major changes yet.

Still haven't redone the tutorials but other than that you should be on your way.

Thumbs up

Hey everyone; Forgot to bump this thread when I released the game. I've gotten sick again so not much progress has been made either dev or promotionally, but I did finish the July 28 release.

Gamejolt link has been updated: https://gamejolt.com/games/ColorsChromatics/248621

Please let me know if you come across any hang ups, I need to know if any accessibility issues exist and your comments really help out. Thanks smile

Thumbs up +2

Hi.
There is propably a bug in the tutorial, I am in the place where is the lesson about placing a markers and locator menu.
So I can set a marker with the shift key and destroy this after activating marker but I see that I can not destroy all markes by pressing ctrl key after creating two markers in random places.
Also in this lesson when I am pressing w key to open locator menu it doesnt works, so I dont know what I have to do in this lesson, because it isnt explained I think, and so I can not skip to the next lesson.

Thumbs up

I'll have to take a look, for now, just skip the tutorial with ESC. The tutorials are the least tested area of the game. You should be able to progress fine after that.

Thumbs up

Hi.
I found another bug.
When I am in the menu during fight where I can select options like fight, magic I can browse this menu by using right arrow key, when I am pressing left arrow, I can not move to the left.

Thumbs up +1

221 (edited by daigonite 2017-08-16 19:52:20)

If you're on "Fight" then it shouldn't go to the left; but I can make it loop around so its easier. sorry about that.

Thumbs up

so is this game yet accessible.

Thumbs up

yes it is you need to edit a file in order to turn this mode on

Thumbs up

224 (edited by daigonite Yesterday 19:51:38)

In order to set up accessible mode, go to config.ini and change access=0 to access=1 and it should be accessible. you can also turn on graphics if you want by setting access_force_graphics=1

I plan on getting an application later for the settings but I keep pushing it to the side to try to put new content into the game.

By the way, Mojsior, I've fixed the issue, somehow focus text wasn't reading on menus when you went left. lol. It will be in the next release though since I've been adding a ton of new code. You can place items on the overworld now and decorate areas.

Thumbs up