where can i find the piece of magic i need it for the miracle egg


What you need to do is to fight the magical ball with the magical edge and switch into reflection mode and once it fires a certain attack it will reflect it if you are facing the ball. Also i have been told if you hit the piece of magic while the ball is close enough to it, the ball will get a nice chunk of damage from that. I'd recommend destroying the ball with that method only when you have enough pieces of magic for the miracle edge though.


the clone generator uses mysterious chips as its ammo, just like in bk2.

An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.


Hi there. Got a question. How, or when does the large box on 1.1 reappeer? I mean when you take it it's gone likely for a long time so When does it reappeer to get like 10 bats for a homerun bat or what ever that is? Oh i hope it's not that when ever i complete a mode it reset my game this box appeers and that's the only way because in that case it takes hell a loooong time to get the homerun bat. Can't wait to return projectiles haha. Thanks for reading

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri


Hi how cani find hiper boomerang i need it for makink javelin


for the box in 1-1, you just store the items it gives you in the warehouse and it'll reappear. Or maybe just store all your plate launcher ammo. But either way if you don't have that stuff in your inventory it will appear.

An anomaly in the matrix. An error in existence. A being who cannot get inside the goddamn box! A.K.A. Me.


wow thank you. I never thought of that. BTW idk what this is but large mines as said, are supposed to deel only 3000 damage but idk how my large mine is deeling 33033 damage and i bought a good tun of them to surprise the bio system with them

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri


What you also ould do is get a clone generator and clone the shit

kind regards and have a nice day,
just you can find me on most multiplayer games with this name lol. If you wish to come in contact with me, just pm me on stw, i'm around there for the most.


Go into stage 16 workshop, then in collection items, go all the way to the bottom and craft some chips, that is what the generator uses.

First, here are my Tactical Battle scripts. https://www.dropbox.com/s/64iuyqnju9csv … h.zip?dl=1
Second, hmm I might put a website address or new game here if I ever make one.
Whaaaaaat! There is nothing here.


I have reached the last room of the penultimate level and have a problem. I'm guessing it's since the update which added the ability to warp to the furthest room you've reached in the level if you died, that this issue has been present.

Possible spoiler information follows.

I'm at the room with the discs which you have to put in the correct order, and find myself without the relevant paper which you collect after killing the mud monster boss. I suspect this is because I died after having collected it, thereby having me lose it, and then have used the warp to skip past it.

I would be very grateful if anybody who has the paper could let me know what the order is, as otherwise I will have to play through all those rooms again, which I was feeling glad were behind me, lol.

If anybody is willing and able to do that, it'd be much appreciated.

I'm both excited and sad to be very near to the final level. It truely is a fantastic game which really sets the bar for what is possible with a 2D audio game if one puts in the time and effort to create it.

Thanks in advance for any help.


For anyone who cares, updated my guide with info about the new switch.

"I used to be an adventurer like you, then I took an arrow in the knee."
guards, skyrim


I'm trying to complete the game on the relevant difficulty to be able to craft the ultra yo-yo. I have reached the final part, where you are controlling the Sky Racer and have to destroy the bio-energy, which I've done without any problems on previous difficulties. This time is proving troublesome, though. I keep getting killed, and having to go through the process of killing the bosses, obtaining the warp launcher, running past the collapsing debris all over again, only to have the exact same thing happen again. As you're limited to moving only left or right, I can't fathom any particular strategy for avoiding being blown to smithereens. On previous attempts I've simply alternated between flying left and right, whilst keeping my thumb down on the spacebar. Unfortunately, that isn't working this time around. I've had a try at checking the list of coordinates for things (with the "D" key), to see whereabouts the bio-energy things are, and then flying in that direction whilst firing away, but that, too, has ended in failure. So I'm just posting here in the vague hope that someone can provide some helpful tips for how to survive it. I want my ultra yo-yo! smile

2,538 (edited by kianoosh 2018-07-11 11:03:10)

This post contains possibly spoilers around getting so much coins. It's not something special, You'll find it if you think a bit but i had to write this before you read it:
The speed of those bio energies don't increase, What you need to do is upgrading your sky racer's hp. Try to get magical ball, Then go defeat it somem ore times as much as you get access to the gold coin collecting part. Then make a saw cruiser, Go back to the gold coin collecting menu, choos endless mode, choos i want powerful bears, set the quantity to 50, Then spawn like 50 ground cruisers by using the saw cruiser that you've built. Mute the bk3 sound within the windows volume mixer, Go watch a movie around 1 hour and a half, come back to the game and you've got more than a good milion coins.
Then go get like 1 milion more hp for your sky racer

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri


Hi all, since some days ago i'fe a problem with buying speed drinks. I should enter a number, and i can see how much i can buy. but now, if I enter the number, I cannot send it. enter do'nt work, with tab i could select the number, but thats all.
the one more thing i can doo is to cancel it with Escape, and i get an small-error sound from my computer, but not an msg box what's wrong.
i'm now at 24.4, and the speed drinks would be hardly neded, but I cannot buy them. earlier there was an list with numbers.
thanks for tips whats wrong, perhaps i should download the game again?


@Vanirf: I have had that issue, as well. I find that if I type in the number I want, then alt+tab out of the game window, then alt+tab back again, and hit enter, that works. No idea what the cause of it not working after typing the number, though.

@Kianoosh: the problem with that is, unless I'm missing something, I have no way of being able to go and increase the health of the Sky Racer. The previous levels are all locked off to me because I'm past the 24-4 boss level, and even starting again by changing the difficulty doesn't solve that issue (I suppose that's a bug: if you reset the game when in the 25-X levels, you're stuck, unable to do anything. It doesn't even allow you to access the 'extra' menu after doing that. Thankfully I made a backup save before I tried changing the difficulty to try that, but if I hadn't... would have been game over. So am still stuck, it seems. Any other suggestions would be welcome.


Hello all. So, I actually found the magical ball and am trying to actually get it by actually fighting it, how ever, using the magical edge doesn't really do much, not even when I put it in reflective mode, attacks still attack me like electrical force and etc. Yall have any strategies as to how I can get this thingy? Thanks all. PS, if there is anyway to level up the magical edge, how do you do it?

Jonathan Candler, A.K.A, Jonnyboy



Hehe, well not only have I completed the final part which I was really struggling with, and crafted myself an ultra yo-yo, but I decided to have another few tries at fighting the magical ball and... well to be perfectly honest I have absolutely no idea what happened. I hit it once or twice and checked it's health to see what the damage was like that I was doing, and it said it was at 98%... and then it died, leaving behind the magical ball weapon. I honestly don't have a clue what happened. Oh well, I'm not complaining. smile

I don't really know of a good strategy for it, though, I'm afraid. I was just trying to keep the magical blades (or whatever that sword is called) in the defense mode until I was near the Magical Ball, and then quickly switch to attack mode and try to get a hit in, before switching back to defense. It really wasn't proving to be a good technique, though - either that or I was just doing a rubbish job of it. tongue

Am pleased it decided to die, though... perhaps it was just getting fed up of me keep trying to kill it and decided it'd give me a helping-hand. smile

Good luck with defeating it.


I'm in Stage 2 and I'm stuck at the room with the switch at 50:12. Any tips?


Yep, magical ball thingy still doesn't wanna let me win, I can reflect all attacks but one. The cycle for me goes like this. fire balls, electric, light and then that attack of which I have no idea of how to get around. Yeah, still need some help here. Regarding stage 2, what part where that switch is again? Kind of don't feel like replaying that stage. Lol.

Jonathan Candler, A.K.A, Jonnyboy


Is the bug regarding the stage locking and mode resetting alive? I thought I had fixed it.
About 2-2, you can look around the terrain  by holding down the G key and arrowing through the field. Take advantage of that function. I really should modify the tutorial a bit so that everyone can know about the feature without having to read the readme file. Actually it is not translated into English, so yeah. Not good. I know.

I really tend to miss direct messages. If you want to contact me privately, please send an email instead of a direct message.


In shops or where ever it asks you for a number, When you done typing it hold down shift and press enter, Action will be performed correctly without needing to go out and back in

Add me on skype: kianoosh.shakeri2
Or follow me on twitter @kianoosh shakeri


@nyanchan Yeah, that's why I wrote as much info about the basics in my guide as I actually did, although some of it is a rather basic description.

"I used to be an adventurer like you, then I took an arrow in the knee."
guards, skyrim


I made it through the level! Yay! smile


What about the iron balls in Stage 3? Can you not get to them until you have the magic hook or something? I'm up at height 20 and I just cannot get up there right now.


@Nyanchan: That bug certainly happened to me, so it seems it's still hanging around in the game.

Also, it would be nice if it were possible to skip the landing scene for the Sky Racer. Since you are able to skip the other scenes in the game, it would make sense if you could do the same with that.